Bug 476727 - rpm query with perms/octal typetag do not work
rpm query with perms/octal typetag do not work
Status: CLOSED DUPLICATE of bug 471820
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 14:28 EST by gerbier
Modified: 2008-12-17 01:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-17 01:40:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gerbier 2008-12-16 14:28:02 EST
Description of problem:
if using :octal or :perms in an rpm query format, the result is "(not a number)"
the query works without this typetag

it is needed for rpmrebuild software

Version-Release number of selected component (if applicable):
rpm-4.6.0-0.rc1.8.i386

How reproducible:
rpm -q --queryformat '[%{FILEMODES:octal} %{FILEMODES:perms} %{FILEMODES} ]' rpm


Steps to Reproduce:
1. just with the rpm query
2.
3.
  
Actual results:
(not a number) (not a number) 33261 /bin/rpm  
(not a number) (not a number) 33261 /etc/cron.daily/rpm  
(not a number) (not a number) 33188 /etc/logrotate.d/rpm  
(not a number) (not a number) 16877 /etc/rpm  
...

Expected results:
755 -rwxr-xr-x 33261 /bin/rpm 
...

Additional info:
Comment 1 Panu Matilainen 2008-12-17 01:40:17 EST

*** This bug has been marked as a duplicate of bug 471820 ***

Note You need to log in before you can comment on or make changes to this bug.