Bug 476887 - Altgr of French keyboard not working in the internal vnc client of virtmanager
Altgr of French keyboard not working in the internal vnc client of virtmanager
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 13:51 EST by Mathieu MILLET
Modified: 2009-07-09 09:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-09 09:18:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch already submitted to qemu-devel list (1.85 KB, patch)
2008-12-17 14:04 EST, Mathieu MILLET
no flags Details | Diff
with the right syntax (1.88 KB, patch)
2008-12-17 14:23 EST, Mathieu MILLET
no flags Details | Diff

  None (edit)
Description Mathieu MILLET 2008-12-17 13:51:44 EST
Description of problem:
The Altgr key (of my french keyboard) is not supported in the internal vnc client of virtmanager.

Version-Release number of selected component (if applicable):
qemu-0.9.1-10.fc10.i386
FYI : 
libvirt-0.5.0-1.fc10.i386
virt-manager-0.6.0-5.fc10.i386
virt-top-1.0.3-2.fc10.i386
virt-viewer-0.0.3-3.fc10.i386
python-virtinst-0.400.0-5.fc10.noarch
libvirt-python-0.5.0-1.fc10.i386
kmod-kqemu-2.6.27.7-134.fc10.i686-1.3.0-0.42.fc10.11.i686
kqemu-1.3.0-0.8.pre11.fc10.noarch
kmod-kqemu-1.3.0-0.42.fc10.11.i686
kmod-kqemu-2.6.27.5-117.fc10.i686-1.3.0-0.42.fc10.9.i686
akmod-kqemu-1.3.0-0.42.fc10.9.i686
qemu-img-0.9.1-10.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. Use a french keyboard
2. Create a VM with "kvm-qemu"
3. try to type "Euro sign" or any letter composed with altgr key ('#', '|', ...) 
  
Actual results:
1. Keys are typed as the altgr key wasn't pressed

Expected results:
Right keys should have been typed

Additional info:
A small patch that seems to correct this issue, have already been submitted to qemu devel list :
http://lists.gnu.org/archive/html/qemu-devel/2008-11/msg00116.html
Comment 1 Mathieu MILLET 2008-12-17 14:04:01 EST
Created attachment 327276 [details]
Patch already submitted to qemu-devel list
Comment 2 Mathieu MILLET 2008-12-17 14:23:47 EST
Created attachment 327278 [details]
with the right syntax
Comment 3 Fedora Admin XMLRPC Client 2009-05-07 08:12:47 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2009-05-07 12:38:21 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Peter Bieringer 2009-05-22 03:14:58 EDT
Same issue hits me, too, with a German keyboard at the host. Looks like this is related to the native VNC client, which as afaik same problems in Linux.
Comment 6 Peter Bieringer 2009-05-25 17:28:40 EDT
Just note that after upgrading to F11 and libvirt-0.6.2-11.fc11, AltGr works as expected on the virtual console at least with German keyboard layout.
Comment 7 Mathieu MILLET 2009-07-09 09:18:44 EDT
Right.

Corrected with F11. ==> Closed

Note You need to log in before you can comment on or make changes to this bug.