Bug 476890 - Deadlock in c++ client connection shutdown
Deadlock in c++ client connection shutdown
Status: CLOSED DUPLICATE of bug 474228
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
1.1
All Linux
high Severity high
: 1.1.1
: ---
Assigned To: Ted Ross
Frantisek Reznicek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 14:23 EST by Ted Ross
Modified: 2015-11-15 19:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-15 12:57:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Ross 2008-12-17 14:23:06 EST
After restarting a qpidd broker, one of the clients attached to it locked up with the following trace:


[root@north-07 ~]# pstack 4224
Thread 3 (Thread 1084229984 (LWP 4245)):
#0  0x00000032c1a0714b in pthread_join () from /lib64/tls/libpthread.so.0
#1  0x0000003b401bedaf in qpid::sys::Thread::join ()
#2  0x0000003b3fb85957 in qpid::client::TCPConnector::closeInternal ()
#3  0x0000003b3fb7cc8a in qpid::client::ConnectionImpl::~ConnectionImpl$delete
#4  0x0000002a957942a5 in boost::detail::sp_counted_base::release ()
#5  0x0000002a9579426c in boost::detail::shared_count::~shared_count ()
#6  0x0000003b3fbd22d3 in qpid::client::SessionImpl::~SessionImpl$delete ()
#7  0x0000003b3fe197f6 in qpid::management::ManagementAgentImpl::ConnectionThread::run () from /usr/lib64/libqmfagent.so.0
#8  0x0000003b401beb7a in qpid::sys::(anonymous namespace)::runRunnable ()
#9  0x00000032c1a06137 in start_thread () from /lib64/tls/libpthread.so.0
#10 0x00000032c0dc9883 in clone () from /lib64/tls/libc.so.6
Thread 2 (Thread 1094719840 (LWP 4246)):
#0  0x00000032c0dc28d6 in __select_nocancel () from /lib64/tls/libc.so.6
#1  0x000000000054671a in sleep ()
#2  0x0000003b3fe1add4 in qpid::management::ManagementAgentImpl::PublishThread::run () from /usr/lib64/libqmfagent.so.0
#3  0x0000003b401beb7a in qpid::sys::(anonymous namespace)::runRunnable ()
#4  0x00000032c1a06137 in start_thread () from /lib64/tls/libpthread.so.0
#5  0x00000032c0dc9883 in clone () from /lib64/tls/libc.so.6
Comment 1 Ted Ross 2008-12-17 14:24:06 EST
The thread that "Thread 3" is attempting to join is, I believe, not listed in the stack trace.
Comment 2 Ted Ross 2009-01-15 12:57:07 EST
Closing as a duplicate of BZ 474228.

*** This bug has been marked as a duplicate of bug 474228 ***

Note You need to log in before you can comment on or make changes to this bug.