Bug 476928 - Routine software update reported a problem with SELinux and rpcbind
Routine software update reported a problem with SELinux and rpcbind
Status: CLOSED DUPLICATE of bug 476585
Product: Fedora
Classification: Fedora
Component: rpcbind (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 20:56 EST by Richard
Modified: 2008-12-18 07:33 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-18 07:33:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard 2008-12-17 20:56:13 EST
Description of problem:
Installing the updates recommended by the standard software update utility in FC9 (Gnome) reported an SELinux problem. The setroubleshoot browser popped up with the following report:
----------------------------------

Summary:

SELinux is preventing rpcbind (rpcbind_t) "setgid" rpcbind_t.

Detailed Description:

SELinux denied access requested by rpcbind. It is not expected that this access
is required by rpcbind and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:rpcbind_t:s0
Target Context                system_u:system_r:rpcbind_t:s0
Target Objects                None [ capability ]
Source                        rpcbind
Source Path                   /sbin/rpcbind
Port                          <Unknown>
Host                          egg.racitup.local
Source RPM Packages           rpcbind-0.1.7-1.fc9
Target RPM Packages           
Policy RPM                    selinux-policy-3.3.1-111.fc9
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     egg.racitup.local
Platform                      Linux egg.racitup.local 2.6.26.6-79.fc9.i686 #1
                              SMP Fri Oct 17 14:52:14 EDT 2008 i686 athlon
Alert Count                   1
First Seen                    Thu 18 Dec 2008 00:46:00 GMT
Last Seen                     Thu 18 Dec 2008 00:46:00 GMT
Local ID                      9a75d3b1-e967-4412-ba44-e24d3913aa02
Line Numbers                  

Raw Audit Messages            

node=egg.racitup.local type=AVC msg=audit(1229561160.456:28): avc:  denied  { setgid } for  pid=3207 comm="rpcbind" capability=6 scontext=system_u:system_r:rpcbind_t:s0 tcontext=system_u:system_r:rpcbind_t:s0 tclass=capability

node=egg.racitup.local type=SYSCALL msg=audit(1229561160.456:28): arch=40000003 syscall=214 success=no exit=-1 a0=20 a1=2db9bc a2=2105b0 a3=bfcc7a50 items=0 ppid=3206 pid=3207 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="rpcbind" exe="/sbin/rpcbind" subj=system_u:system_r:rpcbind_t:s0 key=(null)

----------------------------------

I reported this as soon as it happened so don't know if it has affected the system operation.
Comment 1 Steve Dickson 2008-12-18 07:33:34 EST

*** This bug has been marked as a duplicate of bug 476585 ***

Note You need to log in before you can comment on or make changes to this bug.