Bug 476950 - OpenIPMI does not compile on x86_64 and s390x
OpenIPMI does not compile on x86_64 and s390x
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: OpenIPMI (Show other bugs)
4.8
All Linux
low Severity high
: rc
: ---
Assigned To: Jan Safranek
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 04:27 EST by Karel Volný
Modified: 2009-05-18 16:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:09:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2008-12-18 04:27:02 EST
Description of problem:
the package does not rebuild on x86_64 and s390x because of lib/lib64 issue

the relevant error message is:

gcc -shared  .libs/posix_os_hnd.o .libs/selector.o  -Wl,--rpath
-Wl,/usr/src/redhat/BUILD/OpenIPMI-1.4.14/utils/.libs -Wl,--rpath -Wl,/usr/lib64
../utils/.libs/libOpenIPMIutils.so /usr/lib/libgdbm.so  -m64 -Wl,
-Map -Wl,libOpenIPMIposix.map -Wl,-soname -Wl,libOpenIPMIposix.so.0 -o
.libs/libOpenIPMIposix.so.0.0.1
/usr/lib/libgdbm.so: could not read symbols: File in wrong format


/usr/lib/libgdbm.so is the 32bit version while the 64bit version is
/usr/lib64/libgdbm.so ... if the 32bit package owning the file
(gdbm-devel-1.8.0-24.i386 and gdbm-devel-1.8.0-24.s390 respectively) is
uninstalled, the rebuild fails later saying:

gcc: /usr/lib/libnetsnmp.so: No such file or directory


Version-Release number of selected component (if applicable):
OpenIPMI-1.4.14-1.4E.23

How reproducible:
always on stablesystems
never(?) in Brew

Steps to Reproduce:
1. rpmbuild --rebuild OpenIPMI-1.4.14-1.4E.23.src.rpm
  
Actual results:
see above

Expected results:
binary packages built ...

Additional info:
Comment 1 Jan Safranek 2008-12-18 04:42:14 EST
It's caused by presence of i386 -devel packages on x86_64 systems. I.e. better steps to reproduce (on x86_64):

1. yum install gdbm-devel.i386 gdbm-devel.x86_64 net-snmp-devel.i386 net-snmp-devel-x86_64
2. rpmbuild --rebuild OpenIPMI-1.4.14-1.4E.23.src.rpm
Comment 6 errata-xmlrpc 2009-05-18 16:09:21 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0964.html

Note You need to log in before you can comment on or make changes to this bug.