Bug 476990 - Somehow doesn't like my /etc/yum.repos.d/ files
Somehow doesn't like my /etc/yum.repos.d/ files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 09:59 EST by Matěj Cepl
Modified: 2014-01-21 18:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 14:04:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/yum.repos.d/fedora-rawhide.repo (1.17 KB, text/plain)
2008-12-18 09:59 EST, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2008-12-18 09:59:44 EST
Created attachment 327328 [details]
/etc/yum.repos.d/fedora-rawhide.repo

Description of problem:

[matej@hubmaier ~]$ cd /etc/yum.repos.d/
[matej@hubmaier yum.repos.d]$ grep enabled=1 *
adobe-linux-i386.repo:enabled=1
fedora-rawhide.repo:enabled=1
fedora-rawhide.repo:enabled=1
rpmfusion-free-rawhide.repo:enabled=1
rpmfusion-free-rawhide.repo:enabled=1
rpmfusion-nonfree-rawhide.repo:enabled=1
rpmfusion-nonfree-rawhide.repo:enabled=1
[matej@hubmaier yum.repos.d]$ yum repolist
Loaded plugins: allowdowngrade, changelog, downloadonly, protectbase, refresh-
              : packagekit, remove-with-leaves, security, versionlock
repo id                             repo name                    status
adobe-linux-i386                    Adobe Systems Incorporated   enabled:     17
rpmfusion-free-rawhide              RPM Fusion for Fedora Rawhid enabled:    375
rpmfusion-free-rawhide-debuginfo    RPM Fusion for Fedora Rawhid enabled:    163
rpmfusion-nonfree-rawhide           RPM Fusion for Fedora Rawhid enabled:    147
rpmfusion-nonfree-rawhide-debuginfo RPM Fusion for Fedora Rawhid enabled:     56
[matej@hubmaier yum.repos.d]$ 

What happened to Rawhide repositories?

(my /etc/yum.repos.d/fedora-rawhide.repo is attached)

Version-Release number of selected component (if applicable):
yum-3.2.20-7.fc11.noarch
rpm-4.6.0-0.rc3.2.fc11.x86_64

How reproducible:
100%

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
Rawhide isn't

Expected results:
It should be

Additional info:
Comment 1 Matěj Cepl 2008-12-18 10:05:14 EST
[root@hubmaier ~]# yum repolist all
Loaded plugins: allowdowngrade, changelog, downloadonly, protectbase, refresh-
              : packagekit, remove-with-leaves, security, versionlock
repo id                                     repo name            status
adobe-linux-i386                            Adobe Systems Incorp enabled:     17
fedora                                      Fedora 10.90 - x86_6 disabled
fedora-debuginfo                            Fedora 10.90 - x86_6 disabled
fedora-source                               Fedora 10.90 - Sourc disabled
rawhide-source                              Fedora - Rawhide - S disabled
rpmfusion-free                              RPM Fusion for Fedor disabled
rpmfusion-free-debuginfo                    RPM Fusion for Fedor disabled
rpmfusion-free-rawhide                      RPM Fusion for Fedor enabled:    375
rpmfusion-free-rawhide-debuginfo            RPM Fusion for Fedor enabled:    163
rpmfusion-free-rawhide-source               RPM Fusion for Fedor disabled
rpmfusion-free-source                       RPM Fusion for Fedor disabled
rpmfusion-free-updates                      RPM Fusion for Fedor disabled
rpmfusion-free-updates-debuginfo            RPM Fusion for Fedor disabled
rpmfusion-free-updates-source               RPM Fusion for Fedor disabled
rpmfusion-free-updates-testing              RPM Fusion for Fedor disabled
rpmfusion-free-updates-testing-debuginfo    RPM Fusion for Fedor disabled
rpmfusion-free-updates-testing-source       RPM Fusion for Fedor disabled
rpmfusion-nonfree                           RPM Fusion for Fedor disabled
rpmfusion-nonfree-debuginfo                 RPM Fusion for Fedor disabled
rpmfusion-nonfree-rawhide                   RPM Fusion for Fedor enabled:    147
rpmfusion-nonfree-rawhide-debuginfo         RPM Fusion for Fedor enabled:     56
rpmfusion-nonfree-rawhide-source            RPM Fusion for Fedor disabled
rpmfusion-nonfree-source                    RPM Fusion for Fedor disabled
rpmfusion-nonfree-updates                   RPM Fusion for Fedor disabled
rpmfusion-nonfree-updates-debuginfo         RPM Fusion for Fedor disabled
rpmfusion-nonfree-updates-source            RPM Fusion for Fedor disabled
rpmfusion-nonfree-updates-testing           RPM Fusion for Fedor disabled
rpmfusion-nonfree-updates-testing-debuginfo RPM Fusion for Fedor disabled
rpmfusion-nonfree-updates-testing-source    RPM Fusion for Fedor disabled
updates                                     Fedora 10.90 - x86_6 disabled
updates-debuginfo                           Fedora 10.90 - x86_6 disabled
updates-source                              Fedora 10.90 - Updat disabled
updates-testing                             Fedora 10.90 - x86_6 disabled
updates-testing-debuginfo                   Fedora 10.90 - x86_6 disabled
updates-testing-source                      Fedora 10.90 - Test  disabled
[root@hubmaier ~]#
Comment 2 James Antill 2009-01-07 11:23:22 EST
Is this still happening? What happens if you cp the fedora-rawhide.repo file to tmp.repo or something? Can you upload an strace of a "yum repolist"?
Comment 3 James Antill 2009-01-07 11:25:13 EST
Ok, I just noticed that rawhide-source is there, but disabled ... what does: "yum repolist -v all 'rawhide*'" show? And does "yum list updates" show things from rawhide?
Comment 4 Matěj Cepl 2009-01-07 17:26:41 EST
Ehm:

[root@hubmaier ~]# yum repolist
Loaded plugins: allowdowngrade, changelog, downloadonly, protectbase, refresh-
              : packagekit, security, versionlock
repo id                             repo name                    status
adobe-linux-i386                    Adobe Systems Incorporated   enabled:     17
rpmfusion-free-rawhide              RPM Fusion for Fedora Rawhid enabled:    418
rpmfusion-free-rawhide-debuginfo    RPM Fusion for Fedora Rawhid enabled:    182
rpmfusion-nonfree-rawhide           RPM Fusion for Fedora Rawhid enabled:    180
rpmfusion-nonfree-rawhide-debuginfo RPM Fusion for Fedora Rawhid enabled:     71
[root@hubmaier ~]# yum repolist -v all 'rawhide*'
"remove-with-leaves" plugin is disabled
Loading "changelog" plugin
Loading "versionlock" plugin
Loading "downloadonly" plugin
Loading "protectbase" plugin
Loading "allowdowngrade" plugin
Loading "security" plugin
"blacklist" plugin is disabled
Loading "refresh-packagekit" plugin
"priorities" plugin is disabled
"whiteout" plugin is disabled
Loaded plugins: allowdowngrade, changelog, downloadonly, protectbase, refresh-
              : packagekit, security, versionlock
Running "config" handler for "changelog" plugin
Running "config" handler for "downloadonly" plugin
Running "config" handler for "protectbase" plugin
Running "config" handler for "allowdowngrade" plugin
Running "config" handler for "security" plugin
Config time: 0.415
Yum Version: 3.2.20
COMMAND: yum repolist -v all rawhide* 
Installroot: /
Ext Commands:

   all
   rawhide*
Running "postreposetup" handler for "changelog" plugin
Running "postreposetup" handler for "downloadonly" plugin
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 104, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 343, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 799, in doCommand
    md = repo.repoXML
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1305, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1297, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1287, in _loadRepoXML
    return self._groupLoadRepoXML(text, ["primary"])
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1271, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1112, in _commonLoadRepoXML
    if self._cachingRepoXML(local):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 880, in _cachingRepoXML
    if self.cache or self.metadataCurrent():
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 798, in metadataCurrent
    self._metadataCurrent = self.withinCacheAge(self.metadata_cookie,
AttributeError: 'YumRepository' object has no attribute 'metadata_cookie'
[root@hubmaier ~]# yum list updates
Loaded plugins: allowdowngrade, changelog, downloadonly, protectbase, refresh-
              : packagekit, security, versionlock
Excluding Packages in global exclude list
Finished
Excluding Packages from Adobe Systems Incorporated
Finished
Reading version lock configuration
0 packages excluded due to repository protections
Skipping security plugin, no data
Updated Packages
batik.noarch                         1.7-1.fc11                          rawhide
[root@hubmaier ~]# 

Is that crash related?
Comment 5 James Antill 2009-01-14 10:15:08 EST
It isn't related, it's saying that the repo. wasn't setup ... I can reproduce that, and I've fixed it upstream.

The weird thing is that "list updates" shows you have packages available from rawhide, this makes me think that maybe the problem is that the logger in "repolist" is getting some weird i18n error on the rawhide line, which means it just doesn't output the line.
No idea why repolist would be getting an i18n error for rawhide though, you are in en_US.utf-8, yeh?

Are you running updates regularly (yum-updatesd, PK, or something)? ... as only having one package to update on rawhide is also weird, otherwise.
Comment 6 Matěj Cepl 2009-01-14 10:57:43 EST
Well, running yum upgrade almost every day, but I think there *is* some problem, because I seem not getting them every day and even just a little bit of them.
Comment 7 seth vidal 2009-01-21 14:04:57 EST
yum 3.2.21-3.fc11 which just hit rawhide has  patch which I believe fixes this problem. Please test it.

Note You need to log in before you can comment on or make changes to this bug.