Bug 477013 - X fails to start, map framebuffer
X fails to start, map framebuffer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-sis (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 11:59 EST by Pete Zaitcev
Modified: 2009-03-16 14:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 14:27:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (30.15 KB, text/plain)
2008-12-18 11:59 EST, Pete Zaitcev
no flags Details

  None (edit)
Description Pete Zaitcev 2008-12-18 11:59:13 EST
Created attachment 327339 [details]
Xorg.0.log

Description of problem:

startx fails with the following message:

Fatal server error:
xf86MapVidMem: Could not mmap framebuffer (0x00000000,0x2000) (Invalid argument)

See attached Xorg.0.log.

Version-Release number of selected component (if applicable):

xorg-x11-drv-sis-0.10.0-1.fc9.x86_64
xorg-x11-server-common-1.5.3-5.fc10.x86_64
kernel-2.6.28-0.121.rc7.git5.fc11.x86_64

How reproducible:

100% on the given hardware.

Steps to Reproduce:
1. startx
  
Actual results:

X fails to start

Expected results:

X works

Additional info:

The sis driver wasn't updated ever since libpciaccess was added.
Maybe it needs a rebuild, or many another API change happened?
Unlike libpciaccess, nobody told me. Maybe ajax knows what's up.
Comment 1 Pete Zaitcev 2008-12-26 16:07:51 EST
I updated the Rawhide properly, but same failure occurs.

xorg-x11-drv-sis-0.10.1-1.fc11.x86_64
xorg-x11-server-common-1.5.99.3-4.fc11.x86_64

So, a mere rebuild is not enough to clear this.
Comment 2 Pete Zaitcev 2009-03-16 14:27:32 EDT
Not an issue anymore with xorg-x11-server-common-1.6.0-9.fc11.x86_64,
closing.

Note You need to log in before you can comment on or make changes to this bug.