Bug 477063 - jbossas RPM depends on java 1.5.0
jbossas RPM depends on java 1.5.0
Status: NEW
Product: JBoss Enterprise Application Platform 4
Classification: JBoss
Component: distribution (Show other bugs)
4.3.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Permaine Cheung
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 16:35 EST by Naveen Malik
Modified: 2009-01-20 11:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naveen Malik 2008-12-18 16:35:13 EST
Description of problem:
The jbossas rpm for CP03 has a hard dependency on java 1.5.0.

Version-Release number of selected component (if applicable):
jbossas 4.3.0 GA CP03 RPM
(specifically jbossas-4.3.0-3.GA_CP03.6.2.ep1.el5 RPM)

Expected results:
Expect the dependency to be on java 1.5.0 or greater.

Additional info:
Comment 1 Fernando Nasser 2009-01-20 11:14:18 EST
This is actually correct.  This will only work with Java 5.

To run JBoss AS 4.x on Java 6 one needs to make manual changes etc.

There is a community version of JBoss 4.3 that runs with OpenJDK, it was actually built with it, and it is available from this web site:

jpackage.org

Note You need to log in before you can comment on or make changes to this bug.