Bug 477067 - F9 livecd creation does not include updated packages
F9 livecd creation does not include updated packages
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 16:54 EST by Brian C. Lane
Modified: 2009-01-14 22:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 22:07:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian C. Lane 2008-12-18 16:54:02 EST
Description of problem:

Creating a livecd using the livecd-fedora-9-desktop.ks file doesn't use updated packages because the newkey.i386 repository is not included in the base kickstart file livecd-fedora-9-base-desktop.ks

Solution:

Add this to the /usr/share/livecd-tools/livecd-fedora-9-base-desktop.ks file:

repo --name=updates.newkey --mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f9.newkey&arch=$basearch
Comment 1 Jeremy Katz 2008-12-19 14:04:05 EST
Fixing in git and will be submitting an update to -updates-testing in a bit
Comment 2 Fedora Update System 2008-12-19 14:54:08 EST
livecd-tools-017.2-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/livecd-tools-017.2-1.fc9
Comment 3 Fedora Update System 2008-12-21 03:20:59 EST
livecd-tools-017.2-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update livecd-tools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11556
Comment 4 Fedora Update System 2009-01-14 22:07:46 EST
livecd-tools-017.2-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.