Bug 477088 - Wiki documentation for Anaconda Kickstart is misleading re comps.xml
Wiki documentation for Anaconda Kickstart is misleading re comps.xml
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i686 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Anacond...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 20:18 EST by Henry Grebler
Modified: 2008-12-23 10:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-23 10:50:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henry Grebler 2008-12-18 20:18:49 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2) Gecko/20070220 Firefox/2.0.0.2

See http://fedoraproject.org/wiki/Anaconda/Kickstart
        Chapter 3. Package Selection.

The documentation says, "Refer to the repodata/comps.xml file on the
first CD-ROM..."). On the fist CD-ROM for Fedora 10, there is no file
"repodata/comps.xml". Presumably the documentation refers to
"repodata/Fedora-10-comps.xml". The documentation should perhaps say
"repodata/*comps.xml".


Reproducible: Always

Steps to Reproduce:
1. Visit http://fedoraproject.org/wiki/Anaconda/Kickstart
2. List directory repodata on the first CD-ROM
3.
Actual Results:  
ls /NFS/NLU/CD1/repodata
Fedora-10-comps.xml     filelists.sqlite.bz2  other.xml.gz        repomd.xml
Fedora-10-comps.xml.gz  filelists.xml.gz      primary.sqlite.bz2
TRANS.TBL               other.sqlite.bz2      primary.xml.gz



Expected Results:  
I expected to see a file called comps.xml
Comment 1 Henry Grebler 2008-12-18 20:28:26 EST
The text in the Wiki seems to be the same as the text in

anaconda-11.4.1.58/docs/kickstart-docs.txt
Comment 2 Chris Lumens 2008-12-23 10:50:58 EST
These filenames changed sometime in the F10 cycle (on the HTTP/FTP site for rawhide it's even worse - they're named something like <sha1sum>-comps.xml) and the documentation never changed.  We generate the kickstart-docs.txt file from the wiki page so it's understandable the error would be in both places.

I've updated the wiki page.  Thanks for pointing this out.

Note You need to log in before you can comment on or make changes to this bug.