Bug 477093 - kernel did not used the latest modules when have multi kmod-xenpv installation
kernel did not used the latest modules when have multi kmod-xenpv installation
Status: CLOSED DUPLICATE of bug 404311
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: module-init-tools (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Jon Masters
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 20:48 EST by Joe Jin
Modified: 2009-05-12 17:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 17:29:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for this issue (2.50 KB, patch)
2008-12-18 20:48 EST, Joe Jin
no flags Details | Diff

  None (edit)
Description Joe Jin 2008-12-18 20:48:53 EST
Created attachment 327400 [details]
Patch for this issue

Description of problem:

Install more than one kmod-xenpv packages in the same os, found kernel did not
loaded the right modules, for example, install below kmod-xenpv:
kmod-xenpv-0.1-9.el5
kmod-xenpv-0.1-9.0.1.el5
kernel try to loaded 0.1-9.el5 modules when needed but not 0.1-9.0.1.el5

checked kmod-xenpv scriptlet and found any kmod-xenpv installation will add
weak-modules directly and do not check if have any conflict with new installation,
depmod rules could not deal with this condition very well and always use the 
old installation.

However, we thought use the latest version as weak-module is a good policy.

Attached the patch for above idea, please review.

Thanks,
Joe
Comment 1 Jon Masters 2008-12-22 21:30:50 EST
This is a bug in the weak-modules script, but kmodtool is not where this should be changed. By changing kmodtool, you would only "fix" this for the initial install, and not for subsequent updates, which will use the weak-modules script - that's where the logic should be kept in an ideal world.

It's too late to look at this for RHEL5.3, but I assume you might want an async update prior to RHEL5.4 going out?
Comment 7 Joe Jin 2008-12-24 20:06:03 EST
Agree add something to weak-modules :-)

I think fix it at 5.4 is OK if 5.4 is not too late ;)
Comment 9 Jon Masters 2009-05-12 17:29:56 EDT

*** This bug has been marked as a duplicate of bug 404311 ***

Note You need to log in before you can comment on or make changes to this bug.