Bug 477205 - [LTC 5.4 FEAT] Xen support for 6TB memory [201257]
[LTC 5.4 FEAT] Xen support for 6TB memory [201257]
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.4
All All
high Severity high
: alpha
: 5.4
Assigned To: Chris Lalancette
Martin Jenner
: FutureFeature, OtherQA
Depends On:
Blocks: 445204 460955 483784 488638 488641
  Show dependency treegraph
 
Reported: 2008-12-19 12:02 EST by IBM Bug Proxy
Modified: 2011-12-02 14:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 10:48:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-12-19 12:02:29 EST
=Comment: #0=================================================
Monte R. Knutson <mknutson@us.ibm.com> - 

1. Feature Overview:
Feature Id:	[201257]
a. Name of Feature:	Xen high performance multinode support
b. Feature Description
Further improvements to the Xen hypervisor to become consistent with the base level kernel: amount
of mem (6TB).
 
Customers are looking for improvements to limitation that currently exist with XEN.

Additional Comments:	Approve

2. Feature Details:
Sponsor:	xSeries
Architectures:
x86
x86_64

Arch Specificity: Both
Affects Core Kernel: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from Upstream
d. Upstream Acceptance:	In Progress
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	3rd party code
g. Component Version Target:	Xen Enhancements

3. Business Case
Our flagship multi-node product, x3950 M2, will support up to 96 cpus by the end of 2008.  We are
expecting this number to at least reach 256 logical threads in 2009/2010.  Wtih 16GB DIMMS coming
out, expect the max memory to be as high as 6TB.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Monte Knutson, mknutson@us.ibm.com, 877-894-1495

Technical contact(s):
Kevin Stansell, kstansel@us.ibm.com
Chris McDermott, mcdermoc@us.ibm.com

IBM Manager:
Julio Alvarez, julioa@us.ibm.com
=Comment: #2=================================================
Monte R. Knutson <mknutson@us.ibm.com> - 
IBM will test as soon as OS and hardware is available.  Please let IBM know when complete OS image
can be verified.  Please see Roadmap file delivered at last QBR for information on  availability of
hardware.
Comment 1 John Jarvis 2008-12-19 12:44:04 EST
IBM is signed up to test and provide feedback.
Comment 6 Bill Burns 2009-03-11 10:48:27 EDT
Closing this as can't fix since Xen cannot support more than the presently supported 1TB. In order to support more than that for certification purposes on non-xen another BZ or arrangements for special certification is needed.

Note You need to log in before you can comment on or make changes to this bug.