Bug 477209 - libvte-java-devel: contains oddly named files
libvte-java-devel: contains oddly named files
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvte-java (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Stepan Kasal
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-19 12:04 EST by Tomas Hoger
Modified: 2009-01-30 11:57 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-30 11:57:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Hoger 2008-12-19 12:04:21 EST
Description of problem:
It seems that problem in .spec file causes libvte-java-devel package to contain couple of oddly named files:

# rpm -ql libvte-java-devel | grep name_base
/usr/share/java/%{name_base}0.12-src-0.12.1.zip
/usr/share/java/%{name_base}0.12-src.zip


Version-Release number of selected component (if applicable):
# rpm -q libvte-java-devel
libvte-java-devel-0.12.1-6.el5.i386


Additional info:
Looks like .spec file uses %{name_base} without defining it previously.

Current Fedora versions are not affected, they contain:
/usr/share/java/vte-0.12-src-0.12.1.zip
/usr/share/java/vte-0.12-src.zip

Fedora .spec fix:
http://cvs.fedoraproject.org/viewvc/rpms/libvte-java/devel/libvte-java.spec?r1=1.32&r2=1.33
Comment 3 Stepan Kasal 2009-01-30 11:57:28 EST
libvte is deprecated, and likely to be removed, see bug #466131

Note You need to log in before you can comment on or make changes to this bug.