Bug 477243 - cpg flow control not working, causes aisexec hang.
cpg flow control not working, causes aisexec hang.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
5.2
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Steven Dake
Cluster QE
: ZStream
Depends On:
Blocks: 486389
  Show dependency treegraph
 
Reported: 2008-12-19 14:55 EST by Alan Conway
Modified: 2016-04-26 09:38 EDT (History)
6 users (show)

See Also:
Fixed In Version: openais-0.80.5-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:29:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1366 normal SHIPPED_LIVE openais bug-fix and enhancement update 2009-09-01 07:00:17 EDT

  None (edit)
Description Alan Conway 2008-12-19 14:55:49 EST
Description of problem:

Running a client that mcasts faster than it dispatches, aisexec logs this messages:

Dec 19 17:39:13.126592 [MAIN ] Library queue is full, disconnecting library connection.

and becomes unresponsive, clients attempting to connect hang indefinitely.

How reproducible:

Easy.

Steps to Reproduce:

Run attached client, a modified cpgbench.c that multicasts in one thread and dispatches in another. An even simpler way to reproduce the problem is to take the original cpgbench.c and just comment out the cpg_dispatch line.
Comment 1 Steven Dake 2009-02-18 00:28:20 EST
available in openais-0.80.5-2
Comment 6 errata-xmlrpc 2009-09-02 07:29:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1366.html

Note You need to log in before you can comment on or make changes to this bug.