Bug 477285 - Move away from using eel
Move away from using eel
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-translate (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dmitry Butskoy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-19 20:32 EST by Matthias Clasen
Modified: 2008-12-22 10:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-22 10:03:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2008-12-19 20:32:57 EST
libeel was never meant as a generally available library, it was just some parts of nautilus that were shipped in a separate package. Recently, eel got folded back into nautilus, and there will be no more eel releases. Therefore, longer-term, we will stop shipping the eel2 package. 

Of course, that requires moving the current users of eel away from it. The simplest approach for that would be to just copy the parts of eel that are used in gnome-translate. The slightly less trivial approach would be to port gnome-translate to directly use gtk and other libraries instead of the eel wrappers.
Comment 1 Dmitry Butskoy 2008-12-22 10:03:45 EST
I am aware of it. I'll report this upstream.

eel2 is still present in rawhide. When it will be removed?

Note You need to log in before you can comment on or make changes to this bug.