Bug 477288 - libcdio-devel multilib conflict
libcdio-devel multilib conflict
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libcdio (Show other bugs)
17
All Linux
low Severity medium
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-19 21:10 EST by Philippe Troin
Modified: 2012-08-01 18:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 18:26:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Troin 2008-12-19 21:10:49 EST
Description of problem:

yum install libcdio-devel.i386 install libcdio-devel.x86_64

yields:

  file /usr/include/cdio/version.h conflicts between attempted installs of libcdio-devel-0.80-5.fc10.i386 and libcdio-devel-0.80-5.fc10.x86_64
  file /usr/share/doc/libcdio-devel-0.80/html/version_8h-source.html conflicts between attempted installs of libcdio-devel-0.80-5.fc10.i386 and libcdio-devel-0.80-5.fc10.x86_64
  file /usr/share/doc/libcdio-devel-0.80/html/version_8h.html conflicts between attempted installs of libcdio-devel-0.80-5.fc10.i386 and libcdio-devel-0.80-5.fc10.x86_64
Comment 1 Adrian Reber 2009-02-12 08:13:19 EST
I think this has been fixed in rawhide a few weeks ago with the update to 0.81.
Comment 2 Philippe Troin 2012-06-12 18:56:49 EDT
Reintroduced at some point:

# yum -y install libcdio-devel
Loaded plugins: changelog, downloadonly, priorities, remove-with-leaves, show-
              : leaves, tsflags
16 packages excluded due to repository priority protections
Package libcdio-devel-0.83-3.fc17.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package libcdio-devel.i686 0:0.83-3.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package               Arch         Version                Repository      Size
================================================================================
Installing:
 libcdio-devel         i686         0.83-3.fc17            fedora         457 k

Transaction Summary
================================================================================
Install  1 Package

Total size: 457 k
Installed size: 4.6 M
Downloading Packages:
Running Transaction Check
Running Transaction Test


Transaction Check Error:
  file /usr/include/cdio/cdio_config.h from install of libcdio-devel-0.83-3.fc17.i686 conflicts with file from package libcdio-devel-0.83-3.fc17.x86_64
  file /usr/share/doc/libcdio-devel-0.83/html/cdio__config_8h.html from install of libcdio-devel-0.83-3.fc17.i686 conflicts with file from package libcdio-devel-0.83-3.fc17.x86_64
  file /usr/share/doc/libcdio-devel-0.83/html/cdio__config_8h_source.html from install of libcdio-devel-0.83-3.fc17.i686 conflicts with file from package libcdio-devel-0.83-3.fc17.x86_64
  file /usr/share/doc/libcdio-devel-0.83/html/globals.html from install of libcdio-devel-0.83-3.fc17.i686 conflicts with file from package libcdio-devel-0.83-3.fc17.x86_64
  file /usr/share/doc/libcdio-devel-0.83/html/globals_0x75.html from install of libcdio-devel-0.83-3.fc17.i686 conflicts with file from package libcdio-devel-0.83-3.fc17.x86_64
  file /usr/share/doc/libcdio-devel-0.83/html/globals_defs.html from install of libcdio-devel-0.83-3.fc17.i686 conflicts with file from package libcdio-devel-0.83-3.fc17.x86_64
  file /usr/share/doc/libcdio-devel-0.83/html/globals_defs_0x75.html from install of libcdio-devel-0.83-3.fc17.i686 conflicts with file from package libcdio-devel-0.83-3.fc17.x86_64

Error Summary
-------------

[2]    12200 exit 1     noglob yum -y install libcdio-devel
Comment 3 Fedora Update System 2012-07-24 09:35:08 EDT
libcdio-0.83-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libcdio-0.83-5.fc17
Comment 4 Fedora Update System 2012-07-24 19:27:00 EDT
Package libcdio-0.83-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libcdio-0.83-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11031/libcdio-0.83-5.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-08-01 18:26:13 EDT
libcdio-0.83-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.