Bug 477298 - perl-Test-Warn needs updating to 0.11
perl-Test-Warn needs updating to 0.11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Test-Warn (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-20 00:17 EST by Iain Arnell
Modified: 2009-01-23 21:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 03:50:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Iain Arnell 2008-12-20 00:17:22 EST
Description of problem:

perl-Test-Warn-0.10-3.fc11 fails to build with recently update perl-Sub-Uplevel-0.2002-1.fc11.  According to upstream changelog, this is fixed in Test::Warn 0.11

0.11  Jun 09 2008
        - better Makefile.PL
        - mention Test::Trap
        - uplevel 2 changed to uplevel 1 to work with Sub::Uplevel 0.19_02
        - small fixes



Version-Release number of selected component (if applicable): 0.10-3.fc11


Steps to Reproduce:
1. checkout and build perl-Test-Warn/devel
  
Actual results:

build fails


Expected results:

build succeeds
Comment 1 Paul Howarth 2008-12-20 11:32:21 EST
Updating Test::Warn should also fix the FTBFS on Net::SSLeay:

http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/x86_64/perl-Net-SSLeay-1.35-1.fc10.src.rpm/result/build.log
Comment 3 Paul Howarth 2008-12-20 16:17:37 EST
OK, given that this is affecting quite a few other packages, and that this is one of JPO's packages that's effectively under the maintainership of the perl SIG (IIRC spot is the "legal owner" of all of those packages simply because a group couldn't be made the owner in pkgdb), I've updated it myself:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1012545

I'll leave the ticket open for now in case anyone else (e.g. spot) wants to chime in.
Comment 4 Tom "spot" Callaway 2008-12-20 17:31:24 EST
Works for me. As per usual, I'm okay with perl SIG folks making changes to my perl packages.
Comment 5 Iain Arnell 2008-12-21 02:58:16 EST
Cheers, Paul.  That certainly seems to solve it for the packages I mentioned in comment 2.
Comment 6 Paul Howarth 2008-12-21 03:50:57 EST
OK, I think we're done here then.
Comment 7 Ralf Corsepius 2008-12-21 09:19:32 EST
I think, we should update FC-10 and FC-9, also.
Comment 8 Paul Howarth 2008-12-22 15:58:57 EST
(In reply to comment #7)
> I think, we should update FC-10 and FC-9, also.

Anybody object to me updating F-9 and F-10 the same way?
Comment 9 Fedora Update System 2009-01-05 16:02:50 EST
perl-Test-Warn-0.11-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/perl-Test-Warn-0.11-1.fc10
Comment 10 Fedora Update System 2009-01-05 16:03:39 EST
perl-Test-Warn-0.11-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/perl-Test-Warn-0.11-1.fc9
Comment 11 Fedora Update System 2009-01-23 21:42:11 EST
perl-Test-Warn-0.11-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-01-23 21:43:57 EST
perl-Test-Warn-0.11-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.