Bug 477302 - yum-plugins issue
yum-plugins issue
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-20 02:19 EST by ambrish dhaka
Modified: 2014-01-21 18:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-20 07:43:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ambrish dhaka 2008-12-20 02:19:35 EST
Description of problem:
I enabled yum-plugins=1 by editing yum.conf.
When I use GUI of add-remove software and seek packages this is what I get.
=========
Error Type: <type 'exceptions.TypeError'>
Error Value: 'NoneType' object is unsubscriptable
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2280, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2277, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 611, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 562, in dispatch_command
    self.search_group(options, searchterms)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 438, in search_group
    self._check_init(lazy_cache=True)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1965, in _check_init
    self.yumbase.repos.doSetup()
  File : /usr/lib/python2.5/site-packages/yum/repos.py, line 71, in doSetup
    self.ayum.plugins.run('postreposetup')
  File : /usr/lib/python2.5/site-packages/yum/plugins.py, line 178, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File : /usr/lib/yum-plugins/rpm-warm-cache.py, line 31, in postreposetup_hook
    if commands[0] in ('upgrade', 'install', 'remove'):
==================
Please help me, I have to disable again the plugins, then use add-remove soft GUI.

thanks!
Ambrish Dhaka
Comment 1 Tim Lauridsen 2008-12-20 07:43:24 EST
just remove the 'yum-rpm-warm-cache' plugin, to solve the issue

yum remove yum-rpm-warm-cache

the issue is fixed in yum-utils-1.1.19, just pushed into updates-testing

Note You need to log in before you can comment on or make changes to this bug.