Bug 477325 - vanilla kernels hang randomly on system with RV350 card
vanilla kernels hang randomly on system with RV350 card
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-20 10:56 EST by Bartlomiej Zolnierkiewicz
Modified: 2009-10-22 04:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-22 04:14:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bartlomiej Zolnierkiewicz 2008-12-20 10:56:43 EST
Description of problem:
Vanilla kernels (i.e. 2.6.27, next-20081128, next-20081219) which worked fine with Fedora 9 hang randomly with Fedora 10 on my Pentium M / 855PM / RV350 laptop.

Fedora kernels are not affected since they ship and use CONFIG_DRM_RADEON_KMS.

Version-Release number of selected component (if applicable):
all fc10 versions including xorg-x11-drv-ati-6.9.0-62.fc10.i386

How reproducible:
fully reproducable

Steps to Reproduce:
1. get kernel from kernel.org
2. build it
3. try to use it
  
Actual results:
hang

Expected results:
no hang

Additional info:
Downgrading driver to xorg-x11-drv-ati-6.8.0-19.fc9.i386 fixes hangs.

Same for rebuilding xorg-x11-drv-ati-6.9.0-61.fc10 and reverting radeon-gem-cs branch's commit 5c5736604e6a1bc280821bd92f3714e0c9e7d7d3 ("radeon: no need for this anymore").  Sorry but narrowing it down further the issue is impossible without some help due to complete lack of radeon-gem-cs's bisectability between:

commit 44fb767aa95e5f0725386106b89d0782fd53b768
("radeon: fixup modesetting code after rebasing to master")

and 

commit 12e71eaf7999520d23d50cfbcfc0299b2bdf7a9d
("port to using drm header files")

With xorg-x11-drv-ati-6.9.0-62.fc10 things got worse as it lockups on gdm login screen (surprisingly mouse is still working but that's it...).

More details at:
http://lkml.org/lkml/2008/12/13/77
Comment 1 Jörg Prante 2008-12-22 19:25:07 EST
On Powerbook G4 PPC Fedora 10 with RV350, xorg-x11-drv-ati-6.9.0-62.fc10 also causes hard lockup on gdm login. Just came in via system update... :-(

Thousands of messages in /var/log/gdm/:0.log:

(EE) RADEON(0): Idle timed out, resetting engine...
[mi] EQ overflowing. The server is probably stuck in an infinte loop.

After downgrading to xorg-x11-drv-ati-6.9.0-54.fc10, everything works again.
Comment 2 Bartlomiej Zolnierkiewicz 2009-02-15 13:42:30 EST
The issue still happens with xorg-x11-drv-ati-6.10.0-2.fc10.i386 and 2.6.25-rc5.
Comment 3 Bartlomiej Zolnierkiewicz 2009-02-15 13:43:19 EST
uh, 2.6.29-rc5
Comment 4 Jérôme Glisse 2009-10-15 10:48:47 EDT
Do you still have this issue with fedora 12 (you can test livecd from http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/) ?
Comment 5 Bartlomiej Zolnierkiewicz 2009-10-21 17:24:43 EDT
Sorry, I'm no longer using this machine actively so this bug should probably be closed.
Comment 6 Jérôme Glisse 2009-10-22 04:14:52 EDT
Ok closing this bug, reopen if you ever use the hw again and have the issue with newer fedora like fedora 12.

Note You need to log in before you can comment on or make changes to this bug.