Bug 47748 - /tmp/install.log corrupted.
/tmp/install.log corrupted.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ttfm (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
: 48423 50346 50506 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-06 14:58 EDT by Telsa Gwynne
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-01 15:07:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/install.log with binary chars (108.75 KB, application/octet-stream)
2001-07-13 15:26 EDT, Brock Organ
no flags Details
install.log with weirdo characters (56.70 KB, application/octet-stream)
2001-07-15 06:56 EDT, Telsa Gwynne
no flags Details

  None (edit)
Description Telsa Gwynne 2001-07-06 14:58:18 EDT
Description of Problem:

The start of /tmp/install.log is corrupt following a laptop install
in text mode which died at the final stage but otherwise appeared to
have worked.

In bug 47147 I described a laptop install which resulted in an anaconda
crash at the end but which otherwise appeared to have worked. Looking at
/tmp/install.log I see a top line of
    Module /usr/share/fonts/install/xttfm.ttfm doesn't exist, ignored!
Then I see ^@^@^@^@^@^@ for seven screens, then without a linebreak I
find "Installing umb-scheme." and then it appears normal.

upgrade logs tend to have "The following were available but not
upgraded" at the end. I can't remember whether install logs should
have the same. There wasn't anything those. The final lines were
  Installing xml-i18n-tools.
  /usr/share/xml-i18n-tools directory created with perms 0755.
'file' tells me that /tmp/install.log is a data file.

Is all this down to the failure to complete the installer, or something
else?
Comment 1 Matt Wilson 2001-07-09 12:10:49 EDT
installs don't print out the "following were available but not upgraded."  This
is almost certainly a packaging problem.  Please attach the full log.
Comment 2 Matt Wilson 2001-07-10 13:40:06 EDT
*** Bug 48423 has been marked as a duplicate of this bug. ***
Comment 3 Brock Organ 2001-07-13 15:26:01 EDT
Created attachment 23550 [details]
/tmp/install.log with binary chars
Comment 4 Glen Foster 2001-07-13 15:46:58 EDT
This defect considered MUST-FIX for Fairfax gold-release.
Comment 5 Telsa Gwynne 2001-07-15 06:56:04 EDT
Created attachment 23628 [details]
install.log with weirdo characters
Comment 6 Telsa Gwynne 2001-07-15 06:58:21 EDT
Someone beat me to it, but I can't see 48423. I don't know whether the
few differences are significant or not. I suspect not, but there you are.
Apologies for delay :(
Comment 7 Matt Wilson 2001-07-19 21:50:21 EDT
fixed in cvs
Comment 8 Matt Wilson 2001-08-01 15:06:29 EDT
*** Bug 50506 has been marked as a duplicate of this bug. ***
Comment 9 Matt Wilson 2001-08-01 15:06:36 EDT
*** Bug 50346 has been marked as a duplicate of this bug. ***
Comment 10 Matt Wilson 2001-08-01 15:07:05 EDT
the ttfm package isn't redirecting its output to /dev/null
Comment 11 Matt Wilson 2001-08-01 15:09:54 EDT
rebuilt ttfm package to redirect all %post script output to /dev/null

Note You need to log in before you can comment on or make changes to this bug.