Bug 477500 - depmod has a broken dash-to-underscore conversion
depmod has a broken dash-to-underscore conversion
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jon Masters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-20 23:41 EST by Arjan van de Ven
Modified: 2010-02-25 16:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-25 16:20:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patch (518 bytes, patch)
2008-12-20 23:42 EST, Arjan van de Ven
no flags Details | Diff

  None (edit)
Description Arjan van de Ven 2008-12-20 23:41:35 EST
Description of problem:

with the new .bin format, depmod is writing the wrong thing to the bin files,
as noticed by:

modprobe crc-itu-t

which does not work.
The attached patch fixes this, although I would like to note that having the same common helper in various .c files is a long term maintenance trainwreck waiting to happen, and would suggest making either a common .c file with these, or a header with static inlines.
Comment 1 Arjan van de Ven 2008-12-20 23:42:12 EST
Created attachment 327559 [details]
the patch
Comment 2 Bug Zapper 2009-06-09 06:27:55 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Jon Masters 2010-02-25 16:20:34 EST
Long since fixed bug that was filed under the wrong account.

Note You need to log in before you can comment on or make changes to this bug.