Bug 477511 - Opening folders from "places" menu causes Nautilus to crash
Opening folders from "places" menu causes Nautilus to crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-21 07:14 EST by Jake Shipton
Modified: 2015-03-03 17:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-06 05:18:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jake Shipton 2008-12-21 07:14:55 EST
Description of problem:
If you try to open a folder for example documents from places menu nautilus will crash.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Click places menu
2. Click documents
3. Watch as you loose your desktop icons and cannot open any folders
4. Go to terminal and type nautilus you will see errors (listed below) 
  
Actual results:
Folder opens, and disapears, you loose desktop icons. and can no longer open nautilus. And receive the following from terminal:

$ nautilus
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
Xlib:  extension "Generic Event Extension" missing on display ":0.0".

(nautilus:6877): Unique-DBus-WARNING **: Error while sending message: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(nautilus:6877): Unique-DBus-WARNING **: Error while sending message: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Expected results:

To open the documents folder

Additional info:
I my self did not find this issue. However I am reporting it because a user on Fedora forum opened a topic about it asking for help. I was able to reproduce the issue and confirm it is a bug.
Comment 1 Jake Shipton 2009-01-06 05:18:56 EST
I have re-rested this problem on the following platforms: i386, x86_64. As far as I can tell the issue no longer exists. I've tried it on several machines, and have not been able to reproduce the issue. So I am closing this as it appears to be fixed in the latest Rawhide.

Note You need to log in before you can comment on or make changes to this bug.