Bug 477518 - Lenovo PC 10012 - w/ Intel G33 graphics fails to display
Lenovo PC 10012 - w/ Intel G33 graphics fails to display
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-21 09:09 EST by Tim Burke
Modified: 2008-12-22 22:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-22 11:53:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (63.12 KB, text/plain)
2008-12-21 09:10 EST, Tim Burke
no flags Details
dmesg output (31.10 KB, text/plain)
2008-12-21 09:11 EST, Tim Burke
no flags Details

  None (edit)
Description Tim Burke 2008-12-21 09:09:39 EST
So I went out and bought a new box today.  Attempting to be as Intel generic as possible.

Lenovo PC
Machine Type: 10012
Product Family: 3000 H210
3 G mem

To get the ball rolling, Spot created a USB stick for me of F10.  This works fine in my laptop.  On the new PC, upon booting off the stick, first I see the fedora background fine, then it goes away and nothing ever appears on the display.  If I go to alt consoles I can login as root there, but when switching back to graphics still nothing.

From the boot messages:

Intel Pentium Dual CPU E2200 @2.2G
Linux agpgart interface v0.103
aggart-intel 0000:00:00.0 Intel G33 Chipset
""                                       detected 7164k stolen memory
""                                       AGP apperture is 256M@ 0xd000000
Comment 1 Tim Burke 2008-12-21 09:10:52 EST
Created attachment 327578 [details]
Xorg log file

Attaching Xorg log file
Comment 2 Tim Burke 2008-12-21 09:11:42 EST
Created attachment 327580 [details]
dmesg output
Comment 3 Tim Burke 2008-12-22 11:52:39 EST
This works now on stock F10.  Apparently the cause of the problem was the monitor.  It apparently was lying about what video modes it supports.  If I use a newer monitor it works fine.
Comment 4 Kyle McMartin 2008-12-22 22:34:41 EST
That's really bizarre, Tim. If you get a chance to connect the older monitor,
try

Note You need to log in before you can comment on or make changes to this bug.