Bug 477592 - kxkb shortcut does not change keyboard layout
kxkb shortcut does not change keyboard layout
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 03:27 EST by Boyan Anastasov
Modified: 2008-12-25 11:07 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-25 11:07:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boyan Anastasov 2008-12-22 03:27:30 EST
Description of problem:
I'm not sure which of kxkb or setxkbmap is the cause, but trying to switch keyboard layouts when using the keyboard shortcut does not work.
I have activated option in kxkb - Switching Options, Switch Policy - Application. Pressing the shortcut will change the keyboard, but kkxb does not change the indication. In result the change is global, not per application, and the bad thing is that indication does not show what layout is currently used.

Version-Release number of selected component (if applicable):
Currently versions are:
kdebase-workspace-4.1.85-4.fc11.i386
xorg-x11-xkb-utils-7.2-7.fc10.i386

How reproducible:
In KDE4 open System Settings, go to Regional & Language and click Kayboard Layout.
Add some layout preferably non latin to see the difference better. I'm using BG layout with phonetic variant. The setxkbmap command shown is:

setxkbmap -model pc104 -layout us,bg -variant basic,phonetic

For switching layouts I'm using from Advanced tab Layout switching option "Alt+Shift change layout", but I guess the standard Alt+Ctrl+K will do the same.

I have to say that pressing kxkb indicator with the mouse works correctly as it is set to policy - application.
There is a problem only when using the shortcut.


Steps to Reproduce:
1. Press keyboard shortcut.
 
Actual results:
kxkb layout does not change the indication, but
the layout is changed globally and it is not clear what layout is currently used unless you type some letters.

Expected results:
kxkb to change layout and change indicator only for the current application.

Additional info:
It's not clear for me what package is the cause, because going to older kdebase-workspace didn't changed anything. I even tried with changing back to older xorg-x11-xkb-utils, but no difference.
Comment 1 Kevin Kofler 2008-12-22 04:03:51 EST
This is probably due to evdev, the new combined keyboard and mouse driver used for keyboards since F10 (and for mice since F9). I've read other complaints about setxkbmap working badly with evdev.
Comment 2 Boyan Anastasov 2008-12-25 11:07:16 EST
It appears to be fixed after yesterday's update (23 or 24 December 2008), including updates of xorg. Also xorg-x11-drv-evdev was updated.
Thanks for the fix, I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.