Bug 477657 - notification icon tooltip recommends logging out, but icon menu offers restart computer
notification icon tooltip recommends logging out, but icon menu offers restar...
Status: CLOSED DUPLICATE of bug 475781
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 13:28 EST by Ben Liblit
Modified: 2008-12-24 12:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-24 12:49:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Liblit 2008-12-22 13:28:15 EST
I used gpk-update-viewer to install several package updates, at least one of which requires a session restart.  My notification area now shows an orange warning triangle (⚠).  The tooltip on this icon reads "You will need to log off and log back on".  However, a button-1 mouse click on the icon reveals a menu offering only "Restart computer" and "Hide this icon".

If the sufficient action is to log off and back on, then this warning icon should offer exactly that: a "Log out" menu item.  The "Restart computer" item should only be offered when a restart is truly needed, e.g., on a kernel update.
Comment 1 Richard Hughes 2008-12-24 12:49:05 EST

*** This bug has been marked as a duplicate of bug 475781 ***

Note You need to log in before you can comment on or make changes to this bug.