Bug 477664 - Palimpsest crashes as soon as it is started.
Palimpsest crashes as soon as it is started.
Status: CLOSED DUPLICATE of bug 476839
Product: Fedora
Classification: Fedora
Component: gnome-disk-utility (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 14:24 EST by Simo Sorce
Modified: 2013-03-05 22:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-03 22:06:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simo Sorce 2008-12-22 14:24:30 EST
Description of problem:
Palimsest crashes

Version-Release number of selected component (if applicable):
gnome-disk-utility-0.1-0.git20080720.fc10

How reproducible:
Always

Steps to Reproduce:
1. start it
  
Actual results:
Segfault

Expected results:
no segfaults

Additional info:
Program received signal SIGSEGV, Segmentation fault.
gdu_pool_get_presentables (pool=0x0) at gdu-pool.c:1284
1284	        ret = g_list_copy (pool->priv->presentables);

(gdb) bt
#0  gdu_pool_get_presentables (pool=0x0) at gdu-pool.c:1284
#1  0x08065b73 in update_pool () at gdu-tree.c:68
#2  gdu_device_tree_set_property (object=0x80862a8, prop_id=1, value=0xbfffedd8, pspec=0x80c3a78) at gdu-tree.c:100
#3  0x008bfa71 in object_set_property () at gobject.c:938
#4  g_object_constructor (type=135321296, n_construct_properties=0, construct_params=0x8113cb0) at gobject.c:1348
#5  0x008c01b3 in IA__g_object_newv (object_type=135321296, n_parameters=1, parameters=0x810d460) at gobject.c:1211
#6  0x008c0db2 in IA__g_object_new_valist (object_type=135321296, first_property_name=0x806997a "pool", var_args=0xbfffeffc "") at gobject.c:1315
#7  0x008c0efe in IA__g_object_new (object_type=135321296, first_property_name=0x806997a "pool") at gobject.c:1056
#8  0x08065612 in gdu_device_tree_new (pool=0x0) at gdu-tree.c:422
#9  0x08052da7 in create_window () at gdu-shell.c:1811
#10 gdu_shell_init (shell=0x80ad670) at gdu-shell.c:139
#11 0x008db7a3 in IA__g_type_create_instance (type=134949280) at gtype.c:1674
#12 0x008bf985 in g_object_constructor (type=134949280, n_construct_properties=0, construct_params=0x0) at gobject.c:1334
#13 0x008c01b3 in IA__g_object_newv (object_type=134949280, n_parameters=0, parameters=0x0) at gobject.c:1211
#14 0x008c0d87 in IA__g_object_new_valist (object_type=134949280, first_property_name=0x0, var_args=0xbffff3f8 "") at gobject.c:1274
#15 0x008c0efe in IA__g_object_new (object_type=134949280, first_property_name=0x0) at gobject.c:1056
#16 0x08051d63 in gdu_shell_new () at gdu-shell.c:145
#17 0x0804f812 in main (argc=Cannot access memory at address 0x0
) at gdu-main.c:39
Comment 1 Braden McDaniel 2009-03-03 22:06:59 EST

*** This bug has been marked as a duplicate of bug 476839 ***

Note You need to log in before you can comment on or make changes to this bug.