Bug 477675 - Totem will not play an audio cd
Totem will not play an audio cd
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 15:47 EST by Jeff Rasmussen
Modified: 2009-03-19 11:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 11:44:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Rasmussen 2008-12-22 15:47:34 EST
Description of problem:
Totem will not play an audio cd.
After inserting the cd I receive the following error message:

An error occurred
Could not open location; you might not have permission to open the file.

I have to admit I'm not sure if this is a totem bug or a gstreamer bug.

Version-Release number of selected component (if applicable):
totem-2.24.3-1.fc10
totem-gstreamer-2.24.3-1.fc10
gstreamer-tools-0.10.21-2.fc10

How reproducible:
Every time.

Steps to Reproduce:
1. Insert audio cd.
2. System opens Totem automatically based on my media handling preferences.
3. I receive error message.
Comment 1 Bastien Nocera 2008-12-25 13:16:25 EST
Totem shouldn't even be in the options for playing back audio CDs, because it doesn't play audio CDs (use Rhythmbox, Sound Juicer, or anything else).

How/why did you add it?
Comment 2 Jeff Rasmussen 2008-12-25 14:18:59 EST
I've used Totem to play my audio CDs since Fedora 5, though this is the first time that I've used the gstreamer backend.  I always used the xine-lib backend in the past.

I'm having a problem importing the CD audio into Rhythmbox - which I filed a separate bug for - but I can play my CDs with Sound Juicer with no problem.

To access my media handling preferences, I went to System > Preferences > Personal > File Management > Media > "Choose what happens when inserting media or connecting devices to the system."  On the CD Audio tab I select "Open Media Player" which leads me to believe that the system recognizes Totem as a way to play audio discs.

On older versions of Gnome I remember going into "Removable Media" (or some name close to that) under the system preferences and under CD Audio seeing the command "totem %d".  And like I said before I've always had Totem set as the default player for CDs and this is the first problem I've had with it.
Comment 3 Bastien Nocera 2009-03-19 11:44:49 EDT
Check the content of:
~/.local/share/applications/defaults.list 

And remove the x-content/audio-cdda line from there, which probably mentions totem. Unfortunately, we can't fix that programatically

Note You need to log in before you can comment on or make changes to this bug.