Bug 477682 - RFE: add IPv6 support
RFE: add IPv6 support
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: iptstate (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On: 785467
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 16:53 EST by Peter Bieringer
Modified: 2013-09-11 10:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586120 (view as bug list)
Environment:
Last Closed: 2013-09-11 10:04:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2008-12-22 16:53:00 EST
Description of problem:
iptstate does not show IPv6 connections, but /proc/net/nf_conntrack has some

Version-Release number of selected component (if applicable):
iptstate-2.2.1-3.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. start iptstate
2. open a IPv6 connection e.g. SSH or telnet to an IPv6 webserver
3. check iptstate output
  
Actual results:
IPv6 connection is not shown

Expected results:
IPv6 connection should appear in table
Comment 1 Thomas Woerner 2009-06-03 09:59:56 EDT
iptstate is only capable of displaying IPv4 information, there is no IPv6 support currently. IPv6 support is on the WISHLIST of iptstate, though.
Comment 2 Thomas Woerner 2009-11-10 10:34:50 EST
Assigning to rawhide as a RFE.
Comment 3 nucleo 2012-01-28 21:20:45 EST
IPTState 2.2.3 with IPv6 support released.
Comment 4 Eddie Lania 2012-09-22 10:57:18 EDT
(In reply to comment #3)
> IPTState 2.2.3 with IPv6 support released.

On FC16 i do not see IPTState higher then 2.2.2:

[root@zeus ~]# rpm -q iptstate
iptstate-2.2.2-5.fc15.x86_64

Has it ever been released?
I need ipv6 iptstate support.
Comment 5 Eddie Lania 2013-04-09 06:09:39 EDT
On FC18:

 rpm -q iptstate
iptstate-2.2.2-8.fc18.i686

while iptstate 2.2.5 is already available.

Can somebody update iptstate please?
Comment 6 Thomas Woerner 2013-09-11 10:04:54 EDT
Fixed with iptstate-2.2.5-1 for F-19+

Note You need to log in before you can comment on or make changes to this bug.