Bug 477691 - Keychain init not working without .keychainrc
Keychain init not working without .keychainrc
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: keychain (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Alexander Dalloz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 17:28 EST by Daniel Qarras
Modified: 2008-12-23 02:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-23 02:55:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2008-12-22 17:28:11 EST
Not sure is this by design or a bug:

rm -f ~/.keychainrc
killall ssh-agent
exit

After that during login /etc/profile.d/keychain.sh is not doing anything because it requires ~/.keychainrc to do the actual work.

I think one expects .keychainrc to be for additional options, not a requirement, so missing ~/.keychainrc should not prevent initialization of keychain.
Comment 1 Watanabe, Yuki 2008-12-22 22:06:22 EST
Initializing keychain without .keychainrc means that keychain is invoked whenever a user logs in to the system. I don't think it's a very good idea because it won't be useful for users who don't need/want to use keychain.
Comment 2 Daniel Qarras 2008-12-23 02:55:37 EST
Yep, after thinking this a bit more I fully agree. I'll close this one.

Note You need to log in before you can comment on or make changes to this bug.