Bug 477751 - virt-manager should select a default connection from the list
virt-manager should select a default connection from the list
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 05:45 EST by Mark McLoughlin
Modified: 2009-09-14 11:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-14 11:39:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager-select-added-connection.patch (851 bytes, patch)
2008-12-23 05:45 EST, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Mark McLoughlin 2008-12-23 05:45:28 EST
Created attachment 327746 [details]
virt-manager-select-added-connection.patch

If you start virt-manager, nothing is selected from the list and you have to manually select something before doing anything

A sensible default might be to select a connection by default, patch attached
Comment 1 Cole Robinson 2009-02-15 21:38:15 EST
Okay, I used a couple fixes here:

The above fix, to select a connection after it has been appended to the list (though I forgot to attribute it to you in the commit message. Sorry Mark :/ )

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virt-manager--devel/rev/e2ba569c6609

But since for multiple connections this can seemingly select a random list entry, I committed a fix to explicitly select the first list entry on app startup:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virt-manager--devel/rev/28730e3a48b8

Moving to POST.
Comment 2 Cole Robinson 2009-09-14 11:39:56 EDT
Moving this to F11 and closing as CURRENTRELEASE: not enough of a critical issue to backport.

Note You need to log in before you can comment on or make changes to this bug.