Bug 477782 - Copying to USB Flash Drive Bug
Copying to USB Flash Drive Bug
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: util-linux-ng (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
http://wagmey.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 12:40 EST by Kashif Ahmad Khan
Modified: 2009-06-01 05:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-01 05:03:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kashif Ahmad Khan 2008-12-23 12:40:27 EST
Description of problem: When i copy file of less size (between 1 to 100 mb) to my USB Drive then the file copies correctly and it shows up in the USB flash drive. But when i eject the usb flash drive and plug it in again then the file doesn't exist in the flash drive or sometimes it does exist but have a size of 0 bytes.

But if the file i am copying to that USB Flash Drive is of higher size for example when i copy a 700 mb Movie to it then it is copied correctly and does exist even after ejecting and remount the usb drive. But in this case only sometimes the movie size is less then it's actuall size of 700 mb. 

 My 4 other friends also face the same problem. And only for this copying to flash drive purpose we boot into windows OS and do the job.
Comment 1 Karel Zak 2009-03-19 09:30:53 EDT
(In reply to comment #0)
> Description of problem: When i copy file of less size (between 1 to 100 mb) to
> my USB Drive then the file copies correctly and it shows up in the USB flash
> drive. But when i eject the usb flash drive and plug it in again then the file
> doesn't exist in the flash drive or sometimes it does exist but have a size of
> 0 bytes.

Did you successfully umount the device before you unplug it? Please, check /proc/mounts before you remove the device.
Comment 2 Kashif Ahmad Khan 2009-03-20 09:59:28 EDT
well i've spent some time on it and then came to the conclusion that it only happens when you don't umoun the device before unplugging. 
But in my opinion it still needs maintenance because in windowsOS it works whether you eject the drive through proper way or just grab it out right away ..
 Should you have any questions or concerns, feel free to ask me.
Comment 3 Karel Zak 2009-06-01 05:03:14 EDT
Ah... windowsOS != Linux :-) You have to umount the device before unplugging.

Note You need to log in before you can comment on or make changes to this bug.