Bug 477809 - yum update fails
yum update fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 15:48 EST by Uno Engborg
Modified: 2014-01-21 18:07 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-06 10:58:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Uno Engborg 2008-12-23 15:48:54 EST
Description of problem:

When I do "yum update"  I get:
Loaded plugins: refresh-packagekit
rpmdb: Thread/process 6983/3087210176 failed: Thread died in Berkeley DB library

Then nothing happens.

Versions:
yum-3.2.20-5.fc10.noarch
db4-4.7.25-6.fc10.i386
kernel-2.6.27.7-134.fc10.i686
Comment 1 Gianluca Varisco 2008-12-24 08:13:49 EST
Hi Uno,

If "yum clean all" doesn't fix your problem, would you please try to rebuild your rpmdb and let us know if 'yum update' then works? Follow these steps:

# rm -rf /var/lib/rpm/__db*
# rpm --rebuilddb

Many thanks.
Comment 2 Panu Matilainen 2008-12-29 04:07:52 EST
Uno, is /var/lib/rpm on ext4 filesystem by any chance?
Comment 3 matthew 2008-12-31 13:49:38 EST
Having the same problem on amd64 system. Yum clean all does not help 
(i even get the error while doing that). 
Trying database rebuild. Ok
Repeated yum clean all. Ok

Trying yum check-updates - seems to be okay.

Many thanks.
Comment 4 Gianluca Varisco 2009-01-01 01:02:50 EST
Panu,

Do we have a "rpm --rebuilddb" in the post section of rpm/db* or something similar?

Just curiosity ;-)

Thanks for your help.
Comment 5 Panu Matilainen 2009-01-02 03:31:49 EST
Now that's a horrible idea. There's no evidence here that rebuilddb is needed in any of these cases, it's the BDB environment, not the actual database, that's likely to be corrupted here.

People seeing the "Thread died in Berkeley DB library" errors: what filesystem is /var on? On all cases I've seen so far, it's been ext4 - see bug 468437.
Comment 6 Uno Engborg 2009-01-06 10:50:08 EST
(In reply to comment #1)
> Hi Uno,
> 
> If "yum clean all" doesn't fix your problem, would you please try to rebuild
> your rpmdb and let us know if 'yum update' then works? Follow these steps:
> 
> # rm -rf /var/lib/rpm/__db*
> # rpm --rebuilddb
> 
> Many thanks.


Yes, that fixed the problem. Unless somebody somedboy wants to investigate why it happened this bug could be closed.

Thanks!
Comment 7 Bennet Gedan 2009-01-15 11:49:26 EST
I have exactly the same problems. "yum clean all" does not work and returns the same error as described above. Rebuilding the database did work.

My laptop recently crashed as my batteries ran out of power and gnome-power-manager did not shutdown in time. However the database errors have come with the latest update I did today. I'm NOT using ext4 as filesystem on /var, so this might not be related to bug 468437.

Are there any informations I could supply for further investigations?

Thanks for the rebuilding-command!

bgedan

Note You need to log in before you can comment on or make changes to this bug.