Bug 477813 - Can't install through yum
Can't install through yum
Status: CLOSED WORKSFORME
Product: Fedora EPEL
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 16:37 EST by Jerry Quinn
Modified: 2009-01-18 14:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-18 14:13:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of yum -d8 install java-1.6.0-openjdk 2>&1 |tee yum.log (1.43 KB, text/plain)
2008-12-23 18:04 EST, Jerry Quinn
no flags Details

  None (edit)
Description Jerry Quinn 2008-12-23 16:37:15 EST
Description of problem:

Openjdk is in the EPEL repository.  I can install the prereqs directly using rpm.  But I can't find and install it with yum

[root@smaug ~]# yum search openjdk
Loading "priorities" plugin
Loading "security" plugin
Loading "protectbase" plugin
0 packages excluded due to repository priority protections
0 packages excluded due to repository protections
No Matches found
[root@smaug ~]# yum install java-1.6.0-openjdk
Loading "priorities" plugin
Loading "security" plugin
Loading "protectbase" plugin
0 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Setting up Install Process
Parsing package install arguments
No package java-1.6.0-openjdk available.
Nothing to do


Version-Release number of selected component (if applicable):

Latest version of openjdk there is
http://download.fedora.redhat.com/pub/epel/5/x86_64/java-1.6.0-openjdk-1.6.0.0-1.0.b12.el5.2.x86_64.rpm

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lubomir Rintel 2008-12-23 17:57:21 EST
Thanks for the report.

This seems weird to me, and I suspect there's something wrong with your repository setup, since the package is indeed present in the repository metadata [1].

[1] ftp://download.fedora.redhat.com/pub/epel/5/x86_64/repodata/primary.xml.gz

Could you please increase the debug level, and attache the whole yum output here unless you'll see some obvious problem there? Please do the following:

yum -d8 install java-1.6.0-openjdk 2>&1 |tee yum.log

And attach the yum.log file.
Comment 2 Jerry Quinn 2008-12-23 18:04:31 EST
Created attachment 327778 [details]
Output of yum -d8 install java-1.6.0-openjdk 2>&1 |tee yum.log
Comment 3 Lubomir Rintel 2008-12-24 06:41:06 EST
To me it seems like you have no repositories configured at all, which seems strange. What comes to my mind is:

0.) Do "yum repolist" to find out if you see the repositories.

1.) Do installations of other EPEL packages work? Please try.

2.) Did you do any changes to /etc/yum.conf or /etc/yum.repos.d/epel* files?
If so, please attach the files you find relevant.

Hint: "rpm -V epel-release" will reveal which files changed.

3.) Probably some yum plugin messes it up? --noplugins

4.) Maybe some corrupted repository metadata is cached. You may want to clean it up runnning "yum clean all"

5.) Merry christmas! :)
Comment 4 Lubomir Rintel 2009-01-18 14:13:01 EST
Closing, since there's not response.
Please reopen in case you have more information about this.

Note You need to log in before you can comment on or make changes to this bug.