Bug 477822 - Provides conflict with tk
Provides conflict with tk
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tcl-tile (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 18:14 EST by Michael Schwendt
Modified: 2008-12-23 23:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-23 23:20:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-12-23 18:14:41 EST
tk
    provides tile = 0 0.8.2
tcl-tile
    provides tile = 0 0.8.2 5.fc10
    required by: PySolFC-1.1-7.fc11.noarch

This used to be in package "tile" in Fedora. It's obsoleted by "tk" according to the cvs log and the tk %changelog.

$ wish
% package require tile
0.8.0
Comment 1 Wart 2008-12-23 22:09:23 EST
Looks like another case where tcl-tile was imported even though there was an existing package that had not yet been renamed according to the Tcl packaging guidelines.  FWIW, the tile extension is part of the core Tk 8.5 and is only valid for Tk <= 8.4.
Comment 2 Tom "spot" Callaway 2008-12-23 22:22:16 EST
Whoops. I'll have this properly EOLed after the holidays, my apologies.
Comment 3 Tom "spot" Callaway 2008-12-23 23:20:04 EST
Never mind, I did it tonight. It's dead.packaged in cvs, blocked in F-9/F-10/rawhide.

As far as I know, nothing depended on it, except for tcl-tileqt, which I have fixed to build against tk-devel, and have pushed as updates for F-9/F-10:
https://admin.fedoraproject.org/updates/tcl-tileqt-0.4-0.3.b1.fc9
https://admin.fedoraproject.org/updates/tcl-tileqt-0.4-0.3.b1.fc10

It would be nice for tk to inherit Provides/Obsoletes for tcl-tile.

Closing out this bug.

Note You need to log in before you can comment on or make changes to this bug.