Bug 477873 - yum update FC9 --> FC10
yum update FC9 --> FC10
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-24 11:29 EST by the Spriteman
Modified: 2014-01-21 18:07 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-02 11:40:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of 'yum update perl' (66.35 KB, text/plain)
2009-01-29 03:51 EST, Bill McGonigle
no flags Details

  None (edit)
Description the Spriteman 2008-12-24 11:29:37 EST
DTransaction Summary
================================================================================
Install     99 Package(s)         
Update     924 Package(s)         
Remove       1 Package(s)         

Total size: 1.1 G
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libdb_cxx-4.6.so is needed by (installed) klibido-0.2.5-10.fc9.i386
libdb_cxx-4.6.so is needed by (installed) klibido-0.2.5-8.fc8.i386
libdb_cxx-4.6.so is needed by (installed) klibido-0.2.5-10.fc9.i386
libdb_cxx-4.6.so is needed by (installed) klibido-0.2.5-8.fc8.i386
libldap-2.3.so.0 is needed by (installed) libuser-0.56.6-2.i386
libcrypto.so.6 is needed by (installed) kftpgrabber-0.8.1-3.fc8.i386
libcrypto.so.6 is needed by (installed) distcache-1.4.5-15.i386
libcrypto.so.6 is needed by (installed) libflashsupport-000-0.1.svn20070904.i386
libcrypto.so.6 is needed by (installed) openslp-1.2.1-7.fc8.i386
libcrypto.so.6 is needed by (installed) libssh2-0.18-5.fc8.i386
libssl.so.6 is needed by (installed) kftpgrabber-0.8.1-3.fc8.i386
libssl.so.6 is needed by (installed) distcache-1.4.5-15.i386
libssl.so.6 is needed by (installed) libflashsupport-000-0.1.svn20070904.i386
libssl.so.6 is needed by (installed) libssh2-0.18-5.fc8.i386
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-URI-1.35-3.1.noarch
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-Class-Singleton-1.4-1.fc8.noarch
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-IO-Socket-INET6-2.51-2.fc8.1.noarch
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-Digest-HMAC-1.01-16.noarch
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-HTML-Tagset-3.10-6.fc8.noarch
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-Digest-SHA1-2.11-4.fc8.i386
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-DateTime-Format-W3CDTF-0.04-2.fc7.noarch
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-XML-Parser-2.34-8.i386
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-XML-RSS-1.31-1.fc8.noarch
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-Net-IP-1.25-4.fc8.noarch
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-Newt-1.08-21.fc8.i386
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-Convert-ASN1-0.21-2.fc8.1.noarch
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-String-CRC32-1.4-3.fc8.i386
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-HTML-Parser-3.56-2.fc8.i386
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-BSD-Resource-1.28-3.fc8.i386
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-Net-LibIDN-0.10-1.fc8.i386
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-File-RsyncP-0.68-2.fc8.1.i386
perl(:MODULE_COMPAT_5.8.8) is needed by (installed) perl-DateTime-Format-Mail-0.30-4.fc6.noarch
libpisync.so.0 is needed by (installed) gnome-pilot-2.0.15-10.fc8.i386
mono(glib-sharp) is needed by (installed) gmime-sharp-2.2.10-5.fc8.i386
mono(glib-sharp) is needed by (installed) gmime-sharp-2.2.10-5.fc8.i386
libcap.so.1 is needed by (installed) pinentry-0.7.4-1.fc8.i386
libcap.so.1 is needed by (installed) pinentry-qt-0.7.4-1.fc8.i386
libcap.so.1 is needed by (installed) pinentry-0.7.4-1.fc8.i386
libcap.so.1 is needed by (installed) pinentry-qt-0.7.4-1.fc8.i386
libdb-4.6.so is needed by (installed) klibido-0.2.5-10.fc9.i386
libdb-4.6.so is needed by (installed) klibido-0.2.5-8.fc8.i386
libdb-4.6.so is needed by (installed) klibido-0.2.5-10.fc9.i386
libdb-4.6.so is needed by (installed) klibido-0.2.5-8.fc8.i386
Complete!
(1, [u'Please report this error in bugzilla'])
Comment 1 Panu Matilainen 2008-12-26 08:19:23 EST
This is yum depsolving, not rpm issue.
Comment 2 seth vidal 2008-12-26 09:54:19 EST
What version of yum is this?
Comment 3 seth vidal 2009-01-21 14:01:48 EST
please?
Comment 4 Bill McGonigle 2009-01-29 03:35:35 EST
I'm seeing similar perl(:MODULE_COMPAT_5.8.8) issues trying to update my mythdora install (which is an fc8 base to an fc10 base update). 

I've updated to:
  yum-3.2.20-5.fc10.noarch
  rpm-4.6.0-0.rc1.8.i386
successfully.
Comment 5 Bill McGonigle 2009-01-29 03:51:56 EST
Created attachment 330333 [details]
output of 'yum update perl'
Comment 6 James Antill 2009-02-02 11:40:39 EST
  Bill, your problem is not a yum bug ... it's just saying it can't solve the deps. ... this is "normal". The bug that started this is that yum missed the fact the depsolving didn't work, but rpm caught it.
 However given this bit:

libdb_cxx-4.6.so is needed by (installed) klibido-0.2.5-10.fc9.i386
libdb_cxx-4.6.so is needed by (installed) klibido-0.2.5-8.fc8.i386

...it looks like an interupted transaction is the root of the problem, and there are multiple versions of some packages installed.

 package-cleanup --dupes
 package-cleanup --problems

...will probably fix everything, also 3.2.22 should ship with some work arounds to help
Comment 7 Bill McGonigle 2009-02-02 12:50:43 EST
Thanks, I did manage to get through this one over the weekend by deleting a bunch of packages, upgrading, and re-installing those packages.

However, there were several perl packages that, on f10, required :MODULE_COMPAT_5.10.0 and the 'same' packages on f8 required :MODULE_COMPAT_5.8.8, and even when packing perl and perl-\* into the same transaction, yum (or rpm?) bailed, complaining about depsolving because 5.8.8 was going away.

It was by manually erasing the packages for which it was complaining about the 5.8 dependency that I was able to get the yum upgrade to progress.  I didn't verify all of them, but I did at least check that there were packages with the same package base name in the f10 and f8 repos.  perl-Device-SerialPort was one, IIRC.

Note You need to log in before you can comment on or make changes to this bug.