This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 477927 - at76 is upstream in 2.6.28, patch linux-2.6-at76.patch thus superfluous
at76 is upstream in 2.6.28, patch linux-2.6-at76.patch thus superfluous
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
: 484850 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-25 12:25 EST by Thorsten Leemhuis
Modified: 2009-03-05 17:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 17:27:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2008-12-25 12:25:12 EST
Quoting from kernel.spec:
> Patch690: linux-2.6-at76.patch
[...]
> # Add misc wireless bits from upstream wireless tree
> ApplyPatch linux-2.6-at76.patch
[...]
>* Fri Aug 01 2008 John W. Linville <linville@redhat.com>
>- Revert at76_usb to version from before attempted mac80211 port

This patch is unneeded, as at76 is upstream these days -- it's part of the staging tree/area that was merged into 2.6.28. The sources are apart from two small changes even identical with the ones we use

Version-Release number of selected component (if applicable):
kernel-2.6.28-1.fc11.x86_64

Suggested solution:
Remove patch and use the driver from the staging tree; that way the kernel will also get tainted as soon as the driver gets loaded (that's what upstream does and it's likely the best to follow that example)
Comment 1 John W. Linville 2009-01-05 09:37:58 EST
Seems reasonable, except that there is virtually no guarantee that the staging version will remain working or that anyone will fix it when it breaks.  C'est la vie?

Also, I don't know what (if any) policy we have or need w.r.t. enabling staging drivers?
Comment 2 Thorsten Leemhuis 2009-01-05 14:36:14 EST
(In reply to comment #1)
> Seems reasonable, except that there is virtually no guarantee that the staging
> version will remain working or that anyone will fix it when it breaks.  C'est
> la vie?

Well, the same afaics applies to the driver we include as patch right now, as it nearly the same code base ;-)

So maybe the real solution to for the at76-usb driver is to drop it completely from Fedora...

> Also, I don't know what (if any) policy we have or need w.r.t. enabling staging
> drivers?

That was one of the reasons why I opened this bug. But the decisions is likely up to Davej, Cebbert and Kylem.
Comment 3 John W. Linville 2009-01-05 15:43:59 EST
One difference is that the staging driver will eventually go back to the (broken) mac80211 port of the driver, whereas the version in fedora will remain where it is until we have a working alternative.  As for dropping it, that might be a fine alternative provided you don't mind hurting those users.
Comment 4 Thorsten Leemhuis 2009-01-08 01:21:32 EST
*sigh*

Seems
http://thread.gmane.org/gmane.linux.kernel.wireless.general/26045/focus=26487
was to late.

http://git.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=02227c28391b5059a7710d6039c52912b0ee2c1d

>    Staging: at76_usb: update drivers/staging/at76_usb w/ mac80211 port
>    
>    This updates drivers/staging/at76_usb to correspond with the latest
>    version previously available in wireless-testing.

Which makes this bug mostly irrelevant afaics :-/
Comment 5 John W. Linville 2009-01-08 09:17:46 EST
Crap, confusion...that commit reflects what I was hinting at in comment 3.  Of course, I thought the thread you quoted meant that we all agreed not to commit that -- Greg must have not connected the two points... :-(
Comment 6 Thorsten Leemhuis 2009-02-10 01:25:14 EST
at76 change was reverted afaics:

http://git.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=89cb7e7fd6c0917bb9236ea48bf538d4668ed009

So we could again do now what was suggested in the initial comment of this bug: drop our private at76_usb copy that we patch in and instead use the one from the staging tree
Comment 7 John W. Linville 2009-02-10 10:04:31 EST
*** Bug 484850 has been marked as a duplicate of this bug. ***
Comment 8 John W. Linville 2009-02-11 15:18:42 EST
Change checked-in to rawhide.

Note You need to log in before you can comment on or make changes to this bug.