Bug 477974 - clock-applet doesn't display weather in the panel
clock-applet doesn't display weather in the panel
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
: 469136 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-26 14:00 EST by Braden McDaniel
Modified: 2009-09-09 21:34 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-21 12:16:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preferences "Locations" tab (21.77 KB, image/png)
2008-12-27 12:03 EST, Braden McDaniel
no flags Details
Wether locations (20.71 KB, image/png)
2008-12-27 18:03 EST, Flóki Pálsson
no flags Details
clock without weather but with configured location(s) (108.94 KB, image/png)
2009-01-06 06:51 EST, François Kooman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 529826 None None None Never

  None (edit)
Description Braden McDaniel 2008-12-26 14:00:13 EST
Description of problem:
Even though "Show weather" and "Show temperature" are checked in the preferences, neither of those is displayed in the panel.

Version-Release number of selected component (if applicable):
2.24.2-1.fc10

How reproducible:
Consistently.
Comment 1 Flóki Pálsson 2008-12-27 05:30:18 EST
Which place is selected to show weather for in  the center tab.
Comment 2 Braden McDaniel 2008-12-27 12:03:59 EST
Created attachment 327885 [details]
Preferences "Locations" tab

I'm not sure what you're talking about; there's no apparent option to select a place to show weather in that tab.
Comment 3 Flóki Pálsson 2008-12-27 18:03:53 EST
Created attachment 327892 [details]
Wether locations

I was confused first.  Tray to click on add button. ( first attacment ).
Type inn  field Locations name.  Then a drop down menu appears.
Comment 4 Flóki Pálsson 2008-12-27 18:08:18 EST
The help could be better.
Comment 5 Braden McDaniel 2008-12-28 02:59:53 EST
I'm not sure what the relationship between your suggestion and the reported problem is.  If you're suggesting that I should remove and add back a location, that doesn't help.
Comment 6 Flóki Pálsson 2008-12-28 12:20:46 EST
I was just trying to help. This works fine when you have learned how to use it.

1.  
There is no help  about location in Location window and not in either in Clock Perferences  window. 
2.
There is no title in Location window additional information to select.

"3.1.1. Titles

Give every window a title (with the exception of alerts and toolboxes).  ..."
http://library.gnome.org/devel/hig-book/stable/windows-properties.html.en     

3.

For  Location in Location window there is no hint off additional information to select. 
First impression is that the field is pure text field. 

"Where possible, provide an additional or alternative control that limits the required input to the valid range. ..."
http://library.gnome.org/devel/hig-book/stable/controls-entry.html.en

4.
Location window is for to different things.  
To select time zone or time rule and 
to select weather station.
This should possible bee to different windows.
In most c

5.
What is the purpose to  change Latitude or Longitude.
Comment 7 Braden McDaniel 2008-12-29 05:46:08 EST
As far as I can tell, it doesn't work fine. I know how to add a location. That gets no closer to making the weather information appear in the panel.
Comment 8 Flóki Pálsson 2008-12-29 07:27:05 EST
Well. I am at work and do not have access to fedora.
If I remember.
Click on clock applet. Then locations appears.
On location there is a figure ( house ? ). 
Tray to click on the figures in locations,  then weather information appers in clock applet.
Comment 9 Braden McDaniel 2008-12-29 12:47:13 EST
No, that's not what this bug is about.

The weather and temperature are supposed to display *in the panel* (as I have said from the start). The did in F9. They don't in F10. In the F10 version of the package checking the aforementioned checkboxes for weather and temperature only adds empty space to the applet's footprint in the panel.
Comment 10 Braden McDaniel 2008-12-29 13:43:11 EST
Okay, after rereading comment #8 and experimenting a bit, I finally understand:

A "Set" button appears when moving the pointer over one of the locations listed in the drop-down from the panel applet. Clicking the "Set" button sets a location as the one for which the weather and temperature is displayed in the panel.

So apparently this is "working". There's just an excruciating lack of discoverability in the clock applet UI.
Comment 11 François Kooman 2009-01-06 03:15:58 EST
This doesn't work for me while in F9 everything works as it should.

See also #469136 and http://bugzilla.gnome.org/show_bug.cgi?id=565751
Comment 12 TK009 2009-01-06 05:40:35 EST
*** Bug 469136 has been marked as a duplicate of this bug. ***
Comment 13 TK009 2009-01-06 05:43:25 EST
I am going to close #469136 as a duplicate of this bug rather than the other way around. This report has better information regarding the bug.

@ François
thank you for the heads up and have you tried what Braden has suggested. It would seem the bug is not seeing the "Set" button until you hover the cursor over the configured location. Once the location is "Set" the information correctly appears on the panel. If that doesn't correct the issue for you, please add anything else to this report.

@ Braden
It would seem you've figured out the issue to be due to the invisible "Set" button, making the configuration incomplete, Thanks.
Comment 14 Samuele Farfarini 2009-01-06 05:56:57 EST
As i already said in the bug #469136 the bug interests also the weather applet, and not only the clock panel.
They have the same behaviour.

The location are correctly added in both applet, but icon and temperature does not appear on the panel. There are only two small blank zone who can targeted with the mouse to show the option menu, and nothing else.
Comment 15 François Kooman 2009-01-06 06:50:14 EST
@Edward
I tried that, see attached screenshot. The location is correctly set afaik (the "home" image is set to "Deelen" but the weather indication just doesn't show up. Not sure what you exactly mean by hover over the configured location? I moved the mouse everywhere :-)
Comment 16 François Kooman 2009-01-06 06:51:24 EST
Created attachment 328272 [details]
clock without weather but with configured location(s)
Comment 17 Y-H 2009-01-14 17:22:53 EST
I can confirm the behavior Francois is reporting. I can get the weather to display if I remove the clock, add it back to the panel, and add my city... but the weather display disappears after reboot.
Comment 18 Jon Dufresne 2009-01-17 17:25:34 EST
I am also seeing this behavior in both the clock applet and the weather applet. I add the applet, select a location, and I see the temp and weather in both applets. After I reboot the information is gone in both the clock and the weather applet. Both of these applets worked as expected Fedora 9.
Comment 19 Steevithak 2009-03-13 01:03:42 EDT
The weather/temperature has always worked fine for me in the past, but I noticed since one of the recent updates it has broken and the clock applet no longer displays the temperature or weather. I tried switching to several different locations in my area, thinking perhaps one of the locations had died, but none of them work anymore. Not sure if it's related to this bug or not. Is there any particular information I can provide to help?

The about page says Clock 2.24.3
Comment 20 Steevithak 2009-03-13 01:07:30 EDT
I added the separate weather applet to the toolbar and it works fine, so the problem definitely seems to be with weather portion of the clock applet. Both the weather applet and the clock applet's weather are set to the same location.
Comment 21 Jacob Masaki 2009-03-24 00:11:47 EDT
This problem looks to be caused by the applet starting up and not being able to find weather information initially.  (Granted the UI could be better, but that's a different bug...)  

If one restarts the clock-applet, either by killing it somehow (pkill clock-applet) and telling the panel to reload, or by killing the gnome-panel (or removing and re-adding it, as was suggested earlier) then the clock will show weather information.  

The entire problem appears to be caused by the clock not being aware of NetworkManager, and simply trying *once* to establish a connection.  

A fix would be to change the applet to check if NetworkManager has a connection, and wait until NM does have a connection to connect to a server.  

Even on Ubuntu, where I had the weather initially displaying, if the network went down, the weather applet would die (it would show the icon from before the network went down) and I would have to kill it to get new weather information.  

I'm not sure how it works, but I believe part of why we have NetworkManager around is so that we can signal applications when we lose and gain a connection, right?  Hopefully someone can tell clock-applet this.  :-P

If someone can point me at some documentation for NetworkManager and the clock-applet I could try to fix this myself...  though as a disclaimer, I'm a college student and have never looked at NetworkManager or clock-applet's code...  

But, hey, I'm on spring break, so I've got some time, and if nobody else is taking a stab at it, I may as well take a look and see if I can make any sense of the code...  If I can't, well, then we're back where we started, right?
Comment 22 Steevithak 2009-03-24 11:08:33 EDT
> This problem looks to be caused by the applet starting up and not
> being able to find weather information initially. 

I can confirm this in my case too. I took NetworkManager out of the loop and set up an ONBOOT=yes on my eth0 port so that networking was online by the time the desktop came up. The weather applet works fine. Then I switched back to using NetworkManager and started a network connection after the desktop loaded - result was no weather info. So it looks like there's a bug in the applet that causes the weather portion to crash if networking is not running when the applet loads.
Comment 23 Braden McDaniel 2009-06-21 12:16:28 EDT
The problem that led to this bug report is a UI bug and it does appear to have an upstream equivalent.  Persons observing issues related to NetworkManager are encountering a different bug.
Comment 24 Y-H 2009-06-21 13:20:11 EDT
Problem has disappeared on my system after upgrade to Fedora 11.
Comment 25 Ionut Radu 2009-09-09 05:39:56 EDT
I have fedora 11, and still the temperature is not shown when computer 
boots for the first time. If I reboot it, I get the temperature.

I think the problem is related to the fact that my only internet connection is a HSDPA connection now. When I was using ethernet the problem didn't occur.

The clock applet version is 2.26.3
Kernel is 2.6.29.6-217.2.16.fc11.i586

What is wrong?

Note You need to log in before you can comment on or make changes to this bug.