Bug 478011 - MIGRATED_FROM_JIRA: Need interface to set source primary keys
MIGRATED_FROM_JIRA: Need interface to set source primary keys
Status: CLOSED UPSTREAM
Product: penrose
Classification: Retired
Component: Studio (Show other bugs)
2.0
All Linux
low Severity low
: ---
: ---
Assigned To: Endi Sukma Dewata
Chandrasekar Kannan
:
Depends On:
Blocks: 471500
  Show dependency treegraph
 
Reported: 2008-12-27 02:31 EST by Chandrasekar Kannan
Modified: 2015-01-04 18:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-27 02:31:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2008-12-27 02:31:53 EST
Current problem:

When adding a new source from a JDBC connection, the mapping tool relies on information from the database schema to determine the primary keys for that source. This is not right since user may want to use different fields for mapping purposes.

When adding a new source from a JNDI connection, the mapping tool does not assign any primary keys at all. This is not right since the primary keys are needed to construct the rdn on update operations.

Proposed solution:

We need to have a way to select/modify which fields will be used as the primary keys of a particular source.

Additional Comments From adison dated Mon Apr 18 15:28:06 CDT 2005 
Resolved this issue for the JNDI source.
Currently JDBC source still  relies on database metadata for the primary key information for a particular field.
Comment 1 Chandrasekar Kannan 2008-12-27 02:31:55 EST
Closing bug as it was already closed in Jira - PENROSE-1

Note You need to log in before you can comment on or make changes to this bug.