Bug 478021 - MIGRATED_FROM_JIRA: Need "Write Mapping" and "Source Relationships" for Static entries
MIGRATED_FROM_JIRA: Need "Write Mapping" and "Source Relationships" for Stati...
Status: CLOSED UPSTREAM
Product: penrose
Classification: Retired
Component: Studio (Show other bugs)
2.0
All Linux
low Severity low
: ---
: ---
Assigned To: Endi Sukma Dewata
Chandrasekar Kannan
:
Depends On:
Blocks: 471500
  Show dependency treegraph
 
Reported: 2008-12-27 02:51 EST by Chandrasekar Kannan
Modified: 2015-01-04 18:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-27 02:51:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2008-12-27 02:51:32 EST
As described in http://jira.safehaus.org/browse/PENROSE-7, static entries can also have dynamic attributes. For instance:

dn: cn=MyGroups, ou=groups, dc=safehaus, dc=org
objectClass: groupOfUniqueNames
cn: MyGroups
uniqueMember: cn=user1, ou=users, dc=safehaus, dc=org
uniqueMember: cn=user2, ou=users, dc=safehaus, dc=org
uniqueMember: cn=user3, ou=users, dc=safehaus, dc=org
...

In this example the entry cn=MyGroups, ou=groups, dc=safehaus, dc=org is static, since the dn is fixed, but it has a dynamic attribute uniqueMember which is mapped to a database. If you issue an update operation to this entry, the database might also need to be updated, so you need a way to specify the "Write Mapping" and possibly "Source Relationships" too if it uses several resources.

Additional Comments From adison dated Mon Apr 18 13:41:35 CDT 2005 
Fixed. Both read and write mappings are now available for the mapping (dynamic) entry.


=========================================================
Issue dump from jira
$VAR1 = {
          'priority' => '3',
          'customFieldValues' => [],
          'project' => 'PENROSE',
          'status' => '6',
          'components' => [
                            {
                              'name' => 'Studio',
                              'id' => '10010'
                            }
                          ],
          'reporter' => 'endisd',
          'key' => 'PENROSE-11',
          'assignee' => 'adison',
          'summary' => 'Need "Write Mapping" and "Source Relationships" for Static entries',
          'id' => '10072',
          'updated' => '2007-01-18 14:23:59.0',
          'votes' => '0',
          'fixVersions' => [
                           {
                             'releaseDate' => '2005-06-03 00:00:00.0',
                             'sequence' => '1',
                             'name' => 'Penrose-0.9.1',
                             'released' => 'true',
                             'id' => '10004',
                             'archived' => 'false'
                           }
                         ],
          'affectsVersions' => [],
          'description' => 'As described in http://jira.safehaus.org/browse/PENROSE-7, static entries can also have dynamic attributes. For instance:

dn: cn=MyGroups, ou=groups, dc=safehaus, dc=org
objectClass: groupOfUniqueNames
cn: MyGroups
uniqueMember: cn=user1, ou=users, dc=safehaus, dc=org
uniqueMember: cn=user2, ou=users, dc=safehaus, dc=org
uniqueMember: cn=user3, ou=users, dc=safehaus, dc=org
...

In this example the entry cn=MyGroups, ou=groups, dc=safehaus, dc=org is static, since the dn is fixed, but it has a dynamic attribute uniqueMember which is mapped to a database. If you issue an update operation to this entry, the database might also need to be updated, so you need a way to specify the "Write Mapping" and possibly "Source Relationships" too if it uses several resources.
',
          'created' => '2005-04-14 01:09:34.0',
          'resolution' => '1',
          'type' => '4'
        };


=========================================================
Comment 1 Chandrasekar Kannan 2008-12-27 02:51:34 EST
Closing bug as it was already closed in Jira - PENROSE-11

Note You need to log in before you can comment on or make changes to this bug.