Bug 478036 - MIGRATED_FROM_JIRA: Problems during exit
MIGRATED_FROM_JIRA: Problems during exit
Status: CLOSED UPSTREAM
Product: penrose
Classification: Retired
Component: Studio (Show other bugs)
2.0
All Linux
low Severity low
: ---
: ---
Assigned To: Endi Sukma Dewata
Chandrasekar Kannan
:
Depends On:
Blocks: 471500
  Show dependency treegraph
 
Reported: 2008-12-27 02:52 EST by Chandrasekar Kannan
Modified: 2015-01-04 18:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-27 02:52:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2008-12-27 02:52:49 EST
Make changes to your configuration, then save it. Then select File -> Exit. You will get a warning dialog box saying:

  Are you sure you want to exit?
  You will lose unsaved works!

This is not right since the configuration has been saved. If you click OK, it will close the mapping tool, then displays a dialog box saying:

  JVM terminated. Exit code=1
  ... (snipped) ...

This is also not right, the exit code should be 0.

=========================================================
Issue dump from jira
$VAR1 = {
          'priority' => '4',
          'customFieldValues' => [],
          'project' => 'PENROSE',
          'status' => '6',
          'components' => [
                            {
                              'name' => 'Studio',
                              'id' => '10010'
                            }
                          ],
          'reporter' => 'endisd',
          'key' => 'PENROSE-26',
          'assignee' => 'endisd',
          'summary' => 'Problems during exit',
          'id' => '10091',
          'updated' => '2005-07-07 17:52:13.0',
          'votes' => '0',
          'fixVersions' => [
                           {
                             'releaseDate' => '2005-06-03 00:00:00.0',
                             'sequence' => '1',
                             'name' => 'Penrose-0.9.1',
                             'released' => 'true',
                             'id' => '10004',
                             'archived' => 'false'
                           }
                         ],
          'description' => 'Make changes to your configuration, then save it. Then select File -> Exit. You will get a warning dialog box saying:

  Are you sure you want to exit?
  You will lose unsaved works!

This is not right since the configuration has been saved. If you click OK, it will close the mapping tool, then displays a dialog box saying:

  JVM terminated. Exit code=1
  ... (snipped) ...

This is also not right, the exit code should be 0.',
          'affectsVersions' => [],
          'created' => '2005-05-13 13:55:46.0',
          'environment' => 'Windows',
          'resolution' => '1',
          'type' => '1'
        };


=========================================================
Comment 1 Chandrasekar Kannan 2008-12-27 02:52:51 EST
Closing bug as it was already closed in Jira - PENROSE-26

Note You need to log in before you can comment on or make changes to this bug.