Bug 478038 - MIGRATED_FROM_JIRA: penrose.sh script won't execute under /bin folder
MIGRATED_FROM_JIRA: penrose.sh script won't execute under /bin folder
Status: CLOSED UPSTREAM
Product: penrose
Classification: Retired
Component: Configuration (Show other bugs)
2.0
All Linux
low Severity low
: ---
: ---
Assigned To: Endi Sukma Dewata
Chandrasekar Kannan
:
Depends On:
Blocks: 471500
  Show dependency treegraph
 
Reported: 2008-12-27 02:52 EST by Chandrasekar Kannan
Modified: 2015-01-04 18:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-27 02:53:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2008-12-27 02:52:59 EST
executing penrose.sh under bin/ folder will fail because of no "var" folder under /bin/ folder. 

java "-Djava.ext.dirs=lib" "-Djava.rmi.server.codebase=file:lib/penrose-0.9.jar" org.apache.ldap.server.ServerMain conf/apacheds.properties 2>&1 > var/penrose.out &

Additional Comments From endisd dated Mon May 16 13:49:22 CDT 2005 
The proper way to run Penrose (at least for now) has been documented here:
http://penrose.safehaus.org/Running+Penrose

You need to be in PENROSE_HOME (the installation directory), then run: sh bin/penrose.sh.

But this issue is valid, penrose.sh is currently not executable. This is because the build was done on Windows and the build.xml didn't try to set the file mode.


=========================================================
Issue dump from jira
$VAR1 = {
          'priority' => '5',
          'customFieldValues' => [],
          'project' => 'PENROSE',
          'status' => '6',
          'components' => [
                            {
                              'name' => 'Configuration',
                              'id' => '10014'
                            }
                          ],
          'reporter' => 'jimyang',
          'key' => 'PENROSE-28',
          'assignee' => 'endisd',
          'summary' => 'penrose.sh script won't execute under /bin folder',
          'id' => '10101',
          'updated' => '2005-07-07 17:51:57.0',
          'votes' => '0',
          'fixVersions' => [
                           {
                             'releaseDate' => '2005-06-03 00:00:00.0',
                             'sequence' => '1',
                             'name' => 'Penrose-0.9.1',
                             'released' => 'true',
                             'id' => '10004',
                             'archived' => 'false'
                           }
                         ],
          'affectsVersions' => [],
          'description' => 'executing penrose.sh under bin/ folder will fail because of no "var" folder under /bin/ folder. 

java "-Djava.ext.dirs=lib" "-Djava.rmi.server.codebase=file:lib/penrose-0.9.jar" org.apache.ldap.server.ServerMain conf/apacheds.properties 2>&1 > var/penrose.out &
',
          'created' => '2005-05-16 13:04:23.0',
          'resolution' => '1',
          'type' => '1'
        };


=========================================================
Comment 1 Chandrasekar Kannan 2008-12-27 02:53:01 EST
Closing bug as it was already closed in Jira - PENROSE-28

Note You need to log in before you can comment on or make changes to this bug.