Bug 478062 - MIGRATED_FROM_JIRA: Create double-clickable Penrose Launcher (Macos X)
MIGRATED_FROM_JIRA: Create double-clickable Penrose Launcher (Macos X)
Status: CLOSED UPSTREAM
Product: penrose
Classification: Retired
Component: Studio (Show other bugs)
2.0
All Linux
low Severity low
: ---
: ---
Assigned To: Endi Sukma Dewata
Chandrasekar Kannan
:
Depends On:
Blocks: 471500
  Show dependency treegraph
 
Reported: 2008-12-27 02:55 EST by Chandrasekar Kannan
Modified: 2015-01-04 18:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-27 02:55:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2008-12-27 02:55:29 EST
Can't double click Eclipse.app. 
Additional Comments From jimyang dated Thu Sep 15 22:02:47 CDT 2005 
This is already fix. 

The problem that Eclipse.app is not double-clickable is because ant is removing permissions

Eclipse.app is a directory -- you can see its contents if you open a Terminal and cd into it. The file Eclipse.app\Contents\Info.plist lists a file named eclipse as the CFBundleExecutable, which probably means that Mac OS X expects this file to have executable permissions.

If you look in Eclipse.app\Contents\MacOS\ you'll notice that there are indeed two files with -rwxr-xr-x executable permissions: eclipse and java_swt.

Anyway, at the bottom of Ant's documentation for the <copy> task they note that Unix file permissions are NOT preserved by the <copy> task. D'oh!

Ant <copy> is breaking the launcher because it reduces the file permissions of the two executables to -rw-r--r--. I'll have to figure out how to solve this problem without introducing too much platform-specific code in my Ant build scripts.


Additional Comments From jimyang dated Thu Sep 15 22:04:31 CDT 2005 
This is fixed. Eclipse.app has been renamed to Penrose Studio.app. Also, we fixed the permission problem by modifying ant build.

Additional Comments From jimyang dated Fri Sep 30 19:35:11 CDT 2005 
This is fixed. Eclipse.app has been renamed to Penrose Studio.app. Also, we fixed the permission problem by modifying ant build.

Comment by Jim Yang [17/Sep/05 11:56 AM]  Delete
[ Permlink ]
I created a DMG-based installer for Penrose Studio. (Mac OS X platform) 

1. I moved all the files inside Penrose Studio.app/Contents/MacOS 
2. Modify Penrose Studio.app/Contents/Info.plist startup from ../../../startup.jar to startup.jar 
3. created DMG 

Mac OS X build will be different that any other built because the common practice on Mac OS X is to createa single .app (which is also a folder). You can right-hand click the Penrose Studio.app to "Show package contents"


=========================================================
Issue dump from jira
$VAR1 = {
          'priority' => '3',
          'customFieldValues' => [],
          'project' => 'PENROSE',
          'status' => '6',
          'components' => [
                            {
                              'name' => 'Studio',
                              'id' => '10010'
                            }
                          ],
          'reporter' => 'jimyang',
          'key' => 'PENROSE-64',
          'assignee' => 'jimyang',
          'summary' => 'Create double-clickable Penrose Launcher (Macos X)',
          'id' => '10210',
          'updated' => '2005-09-30 19:35:19.0',
          'votes' => '0',
          'fixVersions' => [
                           {
                             'releaseDate' => '2005-09-15 00:00:00.0',
                             'sequence' => '5',
                             'name' => 'Penrose-0.9.5',
                             'released' => 'true',
                             'id' => '10022',
                             'archived' => 'false'
                           }
                         ],
          'description' => 'Can't double click Eclipse.app. ',
          'affectsVersions' => [
                               {
                                 'releaseDate' => '2005-06-03 00:00:00.0',
                                 'sequence' => '1',
                                 'name' => 'Penrose-0.9.1',
                                 'released' => 'true',
                                 'id' => '10004',
                                 'archived' => 'false'
                               },
                               {
                                 'releaseDate' => '2005-07-06 00:00:00.0',
                                 'sequence' => '2',
                                 'name' => 'Penrose-0.9.2',
                                 'released' => 'true',
                                 'id' => '10005',
                                 'archived' => 'false'
                               },
                               {
                                 'releaseDate' => '2005-07-26 00:00:00.0',
                                 'sequence' => '3',
                                 'name' => 'Penrose-0.9.3',
                                 'released' => 'true',
                                 'id' => '10020',
                                 'archived' => 'false'
                               },
                               {
                                 'releaseDate' => '2005-08-31 00:00:00.0',
                                 'sequence' => '4',
                                 'name' => 'Penrose-0.9.4',
                                 'released' => 'true',
                                 'id' => '10021',
                                 'archived' => 'false'
                               }
                             ],
          'created' => '2005-08-04 11:50:02.0',
          'environment' => 'Mac OS X 10.3.X',
          'resolution' => '1',
          'type' => '1'
        };


=========================================================
Comment 1 Chandrasekar Kannan 2008-12-27 02:55:32 EST
Closing bug as it was already closed in Jira - PENROSE-64

Note You need to log in before you can comment on or make changes to this bug.