Bug 478223 - OpenLDAP Java Backend update
OpenLDAP Java Backend update
Status: NEW
Product: penrose
Classification: Retired
Component: Integration (Show other bugs)
3.0
All Linux
low Severity low
: ---
: ---
Assigned To: Endi Sukma Dewata
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-27 03:09 EST by Chandrasekar Kannan
Modified: 2018-02-07 15:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2008-12-27 03:09:55 EST
supporting  openldap 2.3.35
Additional Comments From jimyang dated Sun Sep 02 13:17:52 CDT 2007 
On Aug 30, 12:26 pm, yingyang <safeh...@gmail.com> wrote:
> Hi,
>
> It's not abandoned. We are bringing up-to-date as we speak. You can
> watch this issuehttp://jira.safehaus.org/browse/PENROSE-252
>
> If you are interested in helping us for this task, please feel free to
> drop me a personal e-mail.

I am interested, actually I already have a patch to make java-backend
trunk compile with openldap 2.3.35. What I am not sure about is
whether to correct the JNI method signatures in utils.c to match the
methods in com.identyx.javabackend.Backend or update the class'
methods so that the backend can at least be initialized by openldap.

Kostas 


=========================================================
Issue dump from jira
$VAR1 = {
          'priority' => '3',
          'customFieldValues' => [],
          'project' => 'PENROSE',
          'status' => '1',
          'components' => [
                            {
                              'name' => 'Integration',
                              'id' => '10018'
                            },
                            {
                              'name' => 'Module',
                              'id' => '10017'
                            }
                          ],
          'reporter' => 'jimyang',
          'key' => 'PENROSE-252',
          'assignee' => 'jimyang',
          'summary' => 'OpenLDAP Java Backend update',
          'id' => '10829',
          'updated' => '2008-01-16 11:37:18.0',
          'votes' => '0',
          'fixVersions' => [
                           {
                             'releaseDate' => '2008-09-18 00:00:00.0',
                             'sequence' => '31',
                             'name' => 'Penrose-2.1',
                             'released' => 'false',
                             'id' => '10130',
                             'archived' => 'false'
                           }
                         ],
          'affectsVersions' => [],
          'description' => 'supporting  openldap 2.3.35',
          'created' => '2007-08-30 04:23:39.0',
          'type' => '4'
        };


=========================================================

Note You need to log in before you can comment on or make changes to this bug.