This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 478238 - Mx4j issue in JAva 1.5 for 0.9.6
Mx4j issue in JAva 1.5 for 0.9.6
Status: CLOSED WONTFIX
Product: penrose
Classification: Retired
Component: Configuration (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Endi Sukma Dewata
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-27 03:11 EST by Chandrasekar Kannan
Modified: 2015-01-04 18:35 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-06 12:48:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2008-12-27 03:11:13 EST
'm using Penrose 0.9.5 server and studio on WinServer 2003 with 
j2se/1.5.0. I'm using an ODBC data souce to SQLServer 2000. I 
successfully created and tested a connection and source--my goal is to 
map the users table in the rdbms to inetorgperson classes for LDAP. 
Under the ou=Users,dc=example,dc=com node I created a dynamic entry 
with an RDN of uid=... I added the source and mapped five fields (i.e. 
sn=namelast, uid=username, postalcode=postalcode, givenname=namefirst, 
cn=namefirst+namelast) both ways from the source to the object and vice 
versa. 

Now, when I preview the ou=Users,dc=example,dc=com entry, I get nothing 
beneath it, in other words, I don't see my dynamic entry. I also tried 
browsing the directory using an ancillary LDAP browser and when I try 
to read or search the ou=Users,dc=example,dc=com entry I get an error 
that the entry can't be read or searched. 

Any ideas? Thanks for any help!! 

I should also mention that I get the following error when I start the 
Penrose server: 

[16/09/2005 10:17:19] mx4j.tools.config.ConfigurationException 
mx4j.tools.config.ConfigurationException 
javax.management.ReflectionException: The MBean class could not be 
loaded by the 
 context classloader 
        at 
com.sun.jmx.mbeanserver.MBeanInstantiatorImpl.loadClass(Unknown Sourc 
e) 
        at 
com.sun.jmx.mbeanserver.MBeanInstantiatorImpl.findClass(Unknown Sourc 
e) 
        at 
com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.createMBean(Unk 
nown Source) 
        at 
com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.createMBean(Unk 
nown Source) 
        at com.sun.jmx.mbeanserver.JmxMBeanServer.createMBean(Unknown 
Source) 
        at 
mx4j.tools.config.DefaultConfigurationBuilder$Create.configure(Defaul 
tConfigurationBuilder.java:548) 
        at 
mx4j.tools.config.DefaultConfigurationBuilder$Startup.configure(Defau 
ltConfigurationBuilder.java:294) 
        at 
mx4j.tools.config.DefaultConfigurationBuilder$Configuration.startup(D 
efaultConfigurationBuilder.java:168) 
        at 
mx4j.tools.config.DefaultConfigurationBuilder$Configuration.configure 
(DefaultConfigurationBuilder.java:151) 
        at 
mx4j.tools.config.ConfigurationLoader.startup(ConfigurationLoader.jav 
a:90) 
        at 
org.safehaus.penrose.PenroseServer.runJmx(PenroseServer.java:136) 
        at 
org.safehaus.penrose.PenroseServer.main(PenroseServer.java:240) 
Caused by: java.lang.ClassNotFoundException: 
mx4j/tools/adaptor/http/HttpAdaptor 

        at java.lang.Class.forName0(Native Method) 
        at java.lang.Class.forName(Unknown Source) 
        ... 12 more 
[16/09/2005 10:17:19] Penrose Server is ready. 

=========================================================
Issue dump from jira
$VAR1 = {
          'priority' => '3',
          'customFieldValues' => [],
          'project' => 'PENROSE',
          'status' => '4',
          'components' => [
                            {
                              'name' => 'Configuration',
                              'id' => '10014'
                            }
                          ],
          'reporter' => 'jimyang',
          'key' => 'PENROSE-270',
          'assignee' => 'jimyang',
          'summary' => 'Mx4j issue in JAva 1.5 for 0.9.6',
          'id' => '10900',
          'updated' => '2008-08-08 10:27:46.0',
          'votes' => '0',
          'fixVersions' => [
                           {
                             'releaseDate' => '2005-10-17 00:00:00.0',
                             'sequence' => '7',
                             'name' => 'Penrose-0.9.7',
                             'released' => 'true',
                             'id' => '10033',
                             'archived' => 'false'
                           }
                         ],
          'affectsVersions' => [
                               {
                                 'releaseDate' => '2005-09-15 00:00:00.0',
                                 'sequence' => '5',
                                 'name' => 'Penrose-0.9.5',
                                 'released' => 'true',
                                 'id' => '10022',
                                 'archived' => 'false'
                               }
                             ],
          'description' => ''m using Penrose 0.9.5 server and studio on WinServer 2003 with 
j2se/1.5.0. I'm using an ODBC data souce to SQLServer 2000. I 
successfully created and tested a connection and source--my goal is to 
map the users table in the rdbms to inetorgperson classes for LDAP. 
Under the ou=Users,dc=example,dc=com node I created a dynamic entry 
with an RDN of uid=... I added the source and mapped five fields (i.e. 
sn=namelast, uid=username, postalcode=postalcode, givenname=namefirst, 
cn=namefirst+namelast) both ways from the source to the object and vice 
versa. 

Now, when I preview the ou=Users,dc=example,dc=com entry, I get nothing 
beneath it, in other words, I don't see my dynamic entry. I also tried 
browsing the directory using an ancillary LDAP browser and when I try 
to read or search the ou=Users,dc=example,dc=com entry I get an error 
that the entry can't be read or searched. 

Any ideas? Thanks for any help!! 

I should also mention that I get the following error when I start the 
Penrose server: 

[16/09/2005 10:17:19] mx4j.tools.config.ConfigurationException 
mx4j.tools.config.ConfigurationException 
javax.management.ReflectionException: The MBean class could not be 
loaded by the 
 context classloader 
        at 
com.sun.jmx.mbeanserver.MBeanInstantiatorImpl.loadClass(Unknown Sourc 
e) 
        at 
com.sun.jmx.mbeanserver.MBeanInstantiatorImpl.findClass(Unknown Sourc 
e) 
        at 
com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.createMBean(Unk 
nown Source) 
        at 
com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.createMBean(Unk 
nown Source) 
        at com.sun.jmx.mbeanserver.JmxMBeanServer.createMBean(Unknown 
Source) 
        at 
mx4j.tools.config.DefaultConfigurationBuilder$Create.configure(Defaul 
tConfigurationBuilder.java:548) 
        at 
mx4j.tools.config.DefaultConfigurationBuilder$Startup.configure(Defau 
ltConfigurationBuilder.java:294) 
        at 
mx4j.tools.config.DefaultConfigurationBuilder$Configuration.startup(D 
efaultConfigurationBuilder.java:168) 
        at 
mx4j.tools.config.DefaultConfigurationBuilder$Configuration.configure 
(DefaultConfigurationBuilder.java:151) 
        at 
mx4j.tools.config.ConfigurationLoader.startup(ConfigurationLoader.jav 
a:90) 
        at 
org.safehaus.penrose.PenroseServer.runJmx(PenroseServer.java:136) 
        at 
org.safehaus.penrose.PenroseServer.main(PenroseServer.java:240) 
Caused by: java.lang.ClassNotFoundException: 
mx4j/tools/adaptor/http/HttpAdaptor 

        at java.lang.Class.forName0(Native Method) 
        at java.lang.Class.forName(Unknown Source) 
        ... 12 more 
[16/09/2005 10:17:19] Penrose Server is ready. ',
          'created' => '2007-10-22 20:56:23.0',
          'environment' => 'WinServer 2003, j2se/1.5.0, ODBC, SQLServer 2000',
          'type' => '1'
        };


=========================================================
Comment 1 Endi Sukma Dewata 2009-01-28 14:32:44 EST
Penrose 2.0 no longer uses MX4J.

Note You need to log in before you can comment on or make changes to this bug.