Bug 47825 - An explicit libtool version has crept into the sources
An explicit libtool version has crept into the sources
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-07 19:34 EDT by R P Herrold
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-12 15:36:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2001-07-07 19:34:26 EDT
Description of Problem:

gdm-2.2.2-4.src.rpm has a bad libtool version which has crept into the
sources

How Reproducible:

Stock RH 7.1, with all updates
Build and install scrollkeeper-0.2-2.src.rpm
Try to gdm-2.2.2-4.src.rpm


Steps to Reproduce:

as above

Actual Results:

<snip>

/bin/sh ../libtool --mode=link gcc  -O2 -march=i386 -mcpu=i686 -g
-Wall         -Wpointer-arith     -Wmissing-prototypes
-Wmissing-declarations   -o gdm  gdm.o display.o slave.o server.o misc.o
auth.o cookie.o xdmcp.o choose.o filecheck.o md5.o verify-pam.o -rdynamic
-L/usr/lib -L/usr/X11R6/lib -lgnome -lgnomesupport -lesd -laudiofile -lm
-ldb1 -lglib -ldl -lSM -lICE -L/usr/lib -L/usr/X11R6/lib -lgtk -lgdk
-rdynamic -lgmodule -lglib -ldl -lXi -lXext -lX11
-lm -lXdmcp -lXau -lX11  /usr/lib/libwrap.a -lnsl -lpam -lXinerama
libtool: ltconfig version `' does not match ltmain.sh version `1.3.5'
Fatal configuration error.  See the libtool docs for more information.
make[2]: *** [gdm] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/gdm-2.2.2/daemon'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/gdm-2.2.2'
make: *** [all-recursive-am] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.88737 (%build)
 
 
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.88737 (%build)

bash-2.04$ rpm -q libtool
libtool-1.3.5-8

bash-2.04$ ls *src.rpm
scrollkeeper-0.2-2.src.rpm
gdm-2.2.2-4.src.rpm 
bash-2.04$


Expected Results:

Clean build

Additional Information:
	
Ask if other elements of build environment are needed
Comment 1 R P Herrold 2001-07-07 20:07:55 EDT
To walk the rawhide build through for gdm, I had to remove aspell, xfig, and
move to:
 
bash-2.04$ rpm -q libtool automake pspell pspell-devel scrollkeeper gdm
libtool-1.4-6
automake-1.4p4-2
pspell-0.12.2-2
pspell-devel-0.12.2-2
scrollkeeper-0.2-2
gdm-2.2.2-4
bash-2.04$

----------------------------------

In process rebuilding xfig, and aspell ...
Comment 2 R P Herrold 2001-07-07 20:38:36 EDT
binutils needed a bounce too, because of some objdump inability to recognize a
new format ...

bash-2.04$ locate objdump | grep dump$
/usr/bin/objdump
bash-2.04$ rpm -qf /usr/bin/objdump
binutils-2.10.91.0.2-3

------------------------------------

xfig needed transfig and htmlview bumped 

------------------------------------
 
bash-2.04$ rpm -q xfig binutils transfig htmlview
xfig-3.2.3d-1
binutils-2.11.90.0.8-3
transfig-3.2.3d-1
htmlview-1.1.0-2
Comment 3 R P Herrold 2001-07-07 21:04:13 EDT
Perhaps versioned build dependencies are in order ?
Comment 4 R P Herrold 2001-07-07 21:10:08 EDT
sudo /usr/sbin/gdmconfig  

--------------  WOW!!!

Worth the effort.
Comment 5 Havoc Pennington 2001-07-12 11:55:58 EDT
gdm 2.2.2 just requires libtool 1.4 to build. It probably runs libtoolize in the
spec file and requires libtool 1.4 for that.
Comment 6 R P Herrold 2001-07-12 15:36:07 EDT
That was the POINT of the filing -- it is an undecumented dependancy

"It probably runs libtoolize in the spec file and requires libtool 1.4 for that"

--- "Probably?"  -- 

If it NEEDS that late a libtool, add a versioned 'BuildRequires:' to teh
specfile; if it does NOT, fix ltmain.sh to OMIT the versioned libtool
requirement.

-- Russ
Comment 7 Havoc Pennington 2001-07-12 15:58:59 EDT
It's just not a high enough priority to make it onto the
will-fix-in-finite-timeframe list.
Comment 8 Havoc Pennington 2001-07-13 17:42:09 EDT
Just to clarify, the issue is that %configure now runs libtoolize, so this is
not a gdm-specific issue. All our SRPMs will tend to be broken if you don't have
the 
automake/autoconf/libtool/gcc/etc. from the release the SRPM is intended for.
Putting explicit dependencies in every package for those would be a lost cause,
you'd never get it right.

Note You need to log in before you can comment on or make changes to this bug.