Bug 478263 - MIGRATED_FROM_JIRA: Incorrect validation of {CRYPT} passwords
MIGRATED_FROM_JIRA: Incorrect validation of {CRYPT} passwords
Status: MODIFIED
Product: penrose
Classification: Retired
Component: Unknown (Show other bugs)
2.0
All Linux
low Severity low
: ---
: ---
Assigned To: Endi Sukma Dewata
Ben Levenson
:
Depends On:
Blocks: 471500
  Show dependency treegraph
 
Reported: 2008-12-27 03:13 EST by Chandrasekar Kannan
Modified: 2015-01-04 19:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2008-12-27 03:13:02 EST
My openldap have shadow passwords starting with {crypt} and {CRYPT} and two forms are ok. With penrose, only lowercase are accepted.
This patch solve the problem for me

Index: core/src/java/org/safehaus/penrose/util/PasswordUtil.java
===================================================================
--- core/src/java/org/safehaus/penrose/util/PasswordUtil.java   (revisi
Comment 1 Chandrasekar Kannan 2008-12-27 03:13:04 EST
Marking bug as MODIFIED as it was already resolved in Jira - PENROSE-298

Note You need to log in before you can comment on or make changes to this bug.