Bug 478296 - /tmp/tmp* files are not deleted; mono-2 BUG
/tmp/tmp* files are not deleted; mono-2 BUG
Status: CLOSED DUPLICATE of bug 465358
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-27 09:10 EST by udo
Modified: 2008-12-28 09:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-28 09:32:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description udo 2008-12-27 09:10:19 EST
Description of problem: /tmp/tmp* files are not deleted, leading to system `halt` in extreme cases


Version-Release number of selected component (if applicable):
0.3.8-13

How reproducible:
Install beagle, beagle-thunderbird, etc and let beagle index various stuff. tmp files will acumulate in /tmp that will not be erased.


Steps to Reproduce:
1. Install beagle, beagle-thunderbird, etc
2. let beagle index various stuff
3. tmp files will acumulate in /tmp that will not be erased
  
Actual results:
/tmp full of tmp* files

Expected results:
No such files

Additional info:
This is a big bug w/ mono-2 and will not remove _any_ tmp file.
files in /tmp are r-- --- --- for my user. 
when files are rw- --- --- the files ARE erased. 
windows weirdness. Windows (and hence .Net) needs write
access to delete a file.
https://bugzilla.novell.com/show_bug.cgi?id=378229

http://bugzilla.gnome.org/show_bug.cgi?id=556068

$ rpm -qa|grep beagle
libbeagle-devel-0.3.5-1.fc9.x86_64
beagle-firefox-0.3.8-13.fc10.x86_64
beagle-thunderbird-0.3.8-13.fc10.x86_64
beagle-gnome-0.3.8-13.fc10.x86_64
beagle-0.3.8-13.fc10.x86_64
libbeagle-0.3.5-1.fc9.x86_64
Comment 2 Adel Gadllah 2008-12-28 09:32:58 EST

*** This bug has been marked as a duplicate of bug 465358 ***

Note You need to log in before you can comment on or make changes to this bug.