Bug 478342 - Missing requires: python-sqlite2
Missing requires: python-sqlite2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gajim (Show other bugs)
10
All Linux
low Severity urgent
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-28 08:47 EST by Mykola Ulianytskyi
Modified: 2009-03-15 13:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-15 23:13:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mykola Ulianytskyi 2008-12-28 08:47:28 EST
Description of problem:
    Missing requires: python-sqlite2

Version-Release number of selected component (if applicable):
    gajim-0.12.1-1

How reproducible:
    Always

Steps to Reproduce:
 $ gajim
Traceback (most recent call last):
  File "gajim.py", line 171, in ?
    from common import gajim
  File "/usr/share/gajim/src/common/gajim.py", line 80, in ?
    import logger
  File "/usr/share/gajim/src/common/logger.py", line 45, in ?
    raise exceptions.PysqliteNotAvailable

  
Additional info:
   Installing python-sqlite2 fixes the problem.
Comment 1 Debarshi Ray 2008-12-28 09:36:01 EST
(In reply to comment #0)
> Traceback (most recent call last):
>   File "gajim.py", line 171, in ?
>     from common import gajim
>   File "/usr/share/gajim/src/common/gajim.py", line 80, in ?
>     import logger
>   File "/usr/share/gajim/src/common/logger.py", line 45, in ?
>     raise exceptions.PysqliteNotAvailable

The relevant code is:

try:
        import sqlite3 as sqlite # python 2.5                                   
except ImportError:
        try:
            	from pysqlite2 import dbapi2 as sqlite
        except ImportError:
		raise exceptions.PysqliteNotAvailable

So python-sqlite2 is only needed when Python 2.5 is not being used. Since Fedora 10 should have Python 2.5, this should not happen.

Do you have another version of Python installed in your system?
Comment 2 Debarshi Ray 2009-01-28 15:48:37 EST
Nikolay, ping?
Comment 3 Mykola Ulianytskyi 2009-01-29 12:22:02 EST
> Do you have another version of Python installed in your system?
Yes
I have rebuilded the package for RHEL 5.2 and got the error.
Sorry, it's my mistake because I didn't verify it on Fedora 10.
Comment 4 Debarshi Ray 2009-02-15 23:13:46 EST
(In reply to comment #3)

> I have rebuilded the package for RHEL 5.2 and got the error.
> Sorry, it's my mistake because I didn't verify it on Fedora 10.

No problem. I will try to find someone who would interested in packaging Gajim for EPEL-5.
Comment 5 Michal Schmidt 2009-03-15 13:07:59 EDT
FYI, Gajim is now in epel-testing for EL-5.
Michal

Note You need to log in before you can comment on or make changes to this bug.