Bug 478374 - Segmentation fault in '/usr/lib/gstreamer-0.10/libgstffmpeg.so' from package gstreamer-ffmpeg-0.10.5-1.i386
Segmentation fault in '/usr/lib/gstreamer-0.10/libgstffmpeg.so' from package ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-28 22:37 EST by GJahchan
Modified: 2009-01-01 13:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-01 13:04:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description GJahchan 2008-12-28 22:37:26 EST
Description of problem: Segmentation fault in libgstffmpeg.so


Version-Release number of selected component (if applicable): gstreamer-ffmpeg-0.10.5-1.i386


How reproducible: Always


Steps to Reproduce:
1. Open Gnome Desktop
2.
3.
  
Actual results: The following message when starting Gnome:

There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The last error message was:

Message did not receive a reply (timeout by message bus)

GNOME will still try to restart the Settings Daemon next time you log in.

Expected results: No errors when starting Gnome before upgrading to gstreamer-ffmpeg-0.10.5-1.i386

Additional info:

The problem is with: /usr/lib/gstreamer-0.10/libgstffmpeg.so

See the results of a manual startup of gnome-settings-daemon with libgstffmpeg.so as is and with the library renamed so it will not load.

                    [Start gnome-settings-daemon manually]
$ /usr/libexec/gnome-settings-daemon
CRTC 84 Timestamp: 242388
Output 85 Timestamp: 242388
CRTC 84 Timestamp: 242388
Output 85 Timestamp: 242388
Shutdown failed or nothing to shut down.
[1230500581,000,xklavier.c:xkl_engine_start_listen/] 	The backend does not require manual layout management - but it is provided by the application
ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.10/libgstffmpeg.so

Please either:
- remove it and restart.
- run with --gst-disable-segtrap and debug.
0:00:00.045793431  9173  0x90abf00 ERROR             GST_INIT gst.c:857:ensure_current_registry_forking: child did not exit normally, terminated by signal
[1230500581,000,xklavier.c:xkl_engine_start_listen/] 	The backend does not require manual layout management - but it is provided by the applicationCould not initialize GStreamer: Error re-scanning registry , child terminated by signal
                  [Renamed it below to libgstffmpeg.so.bad]
$ sudo mv -v /usr/lib/gstreamer-0.10/libgstffmpeg.so /usr/lib/gstreamer-0.10/libgstffmpeg.so.bad
Password or swipe finger: 
`/usr/lib/gstreamer-0.10/libgstffmpeg.so' -> `/usr/lib/gstreamer-0.10/libgstffmpeg.so.bad'
           [One more try with libgstffmpeg.so out of the picture]
$ /usr/libexec/gnome-settings-daemon
CRTC 84 Timestamp: 242388
Output 85 Timestamp: 242388
CRTC 84 Timestamp: 242388
Output 85 Timestamp: 242388
Shutdown failed or nothing to shut down.
xrdb:  "*Label.background" on line 220 overrides entry on line 150
xrdb:  "*Text.background" on line 226 overrides entry on line 191
xrdb:  "*Label.foreground" on line 232 overrides entry on line 151
xrdb:  "*Text.foreground" on line 238 overrides entry on line 192
xrdb:  "*Label.background" on line 220 overrides entry on line 150
xrdb:  "*Text.background" on line 226 overrides entry on line 191
xrdb:  "*Label.foreground" on line 232 overrides entry on line 151
xrdb:  "*Text.foreground" on line 238 overrides entry on line 192
xrdb:  "*Label.background" on line 220 overrides entry on line 150
xrdb:  "*Text.background" on line 226 overrides entry on line 191
xrdb:  "*Label.foreground" on line 232 overrides entry on line 151
xrdb:  "*Text.foreground" on line 238 overrides entry on line 192

[gnome-settings-daemon starts up without any errors and loads my usual desktop settings].
Comment 1 Rex Dieter 2009-01-01 13:04:41 EST
closing->wontfix
gstreamer-ffmpeg is not distributed by the fedora project.  You probably meant to use bugzilla.rpmfusion.org

Note You need to log in before you can comment on or make changes to this bug.