Bug 478380 - Gettimeofday(2) Off-by-one after Settimeofday(2)
Gettimeofday(2) Off-by-one after Settimeofday(2)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.7
ia64 Linux
medium Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-29 02:08 EST by CAI Qian
Modified: 2009-01-05 10:45 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 10:45:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reproducer (1.03 KB, text/plain)
2008-12-29 02:12 EST, CAI Qian
no flags Details

  None (edit)
Description CAI Qian 2008-12-29 02:08:25 EST
Description of problem:
On all (at least 5) IA-64 machines tested, the following test will fail,

curr_time = gettimeofday()
settimeofday (curr_time + 10)
pres_time = gettimeofday()

The result that gettimeofday() returned was one less that we set.

# ./time
curr_time = 1228827598
pres_time = 1228827607
Failed.

Version-Release number of selected component (if applicable):
kernel-2.6.9-78.EL
kernel-2.6.9-78.0.12.EL

How reproducible:
always

Steps to Reproduce:
1. run the reproducer
  
Actual results:
The test failed.

Expected results:
The test should pass.


Additional info:
* I have only seen this on IA-64.
* I have only seen this on RHEL 4.
* RHEL 5 has the same behaviour if using time() instead of gettimeofday.
Bug 475477 - Time(2) Off-by-one after Settimeofday(2)
Comment 1 CAI Qian 2008-12-29 02:12:38 EST
Created attachment 327913 [details]
reproducer
Comment 2 CAI Qian 2008-12-29 02:40:41 EST
By the way, NTP has been stopped during the test.
Comment 3 Prarit Bhargava 2009-01-05 10:45:53 EST
Since this is RHEL4 ia64, and we're at the end of development, I'm closing this as WONTFIX.

P.

Note You need to log in before you can comment on or make changes to this bug.